ShiftPhone Shift6mq - eOS installation problem

Hi all,

While using eOS v1.5 R on my paid FP3+, I wanted to use eOS on my wife’s Shiftphone Shift6mq, which is supported by Murena.

It was the first time ever I open a command prompt but I figured out how it work to command the phone from there. I followed the guide attached to my device. The device was found with the command “adb devices”. Then I needed to run the “adb reboot bootloader”, which was a success. But then, from the fastboot mode, the device is not found anymore and the command is waiting indefinitively for a device. The device is for this reason still locked

I tried to update the Android drivers but nothing is ever found (and I didn’t as well on the web). The adb/fastboot are up to date from the link provided in the documentation. Really, I don’t know how to continue. But I’m keen to try if any one could be of some help. Ah and I’m running Windows 10.

Keep fingers crossed :crossed_fingers:

“Waiting for device” might be different from the conclusion that the device is locked, idk … but you might use Windows device manager to ensure you have fully dealt with the drivers issue.

In this thread (for a different device) I described a way to check with Windows update. Installation- received a “< waiting for any device” message - #2 by aibd

In the documentation Install /e/OS on a SHIFT SHIFT6mq - “axolotl” we see that fastboot devices has to succeed before Unlocking the bootloader.

Here is another “Waiting for any device” post *waiting for any device* issue when installing FP4 -> SOLVED

1 Like

Hi !

Thanks for your quick answer and the proposed solution. With your help, I finally managed to install eOS on my Axolotl :slight_smile: :champagne:.

For me, your last link was the one to follow in order to solve the yellow triangle shown while in Fastboot (waiting for any device issue when installing FP4 → SOLVED - /e/OS Devices / Fairphone - /e/ community).

You may be of some help with this question : when I’m restarting the phone, it says that the phone is unlock. I don’t have such message on my paid FP3+. Do I need to relock it via Command Prompt and is it not possible in order to run eOS properly ? I’m not sure :man_shrugging:.

In addition, I did not have always the same message as described in the installation guide. Any clue who / how could I forward my own experience to allow others to benefit from it ?

Thanks for the time taken :+1:

Good to hear that /e/ installed successfully for you.

The install instructions would include the instruction to lock the bootloader if both the device and the /e/ ROM were suitable. In the case of this phone relocking the bootloader is not included and it would be a mistake to try. You cannot currently relock the bootloader on this device when the /e/ ROM is installed.

I ran this search of the forum for “relock bootloader” the subject has come up many times but I did not find one definitive “good answer” !

FP3 is one of the few phones where relocking the bootloader is available for /e/.

Another significant thing is that Android requires that the device announce when the bootloader is unlocked. On some device one might see something like a little padlock sign, on other devices it might be a much more intrusive text based warning.

… sorry, which message ?

1 Like

Hi,

I was talking about this message “Script succeeded result was [1.000000]”. In the guide, it says that a message similar to this should appears while the installation is completed. In my case, i just got a 1/2 followed by 2/2 and nothing else. I founded hard to be sure the package was installed completely or not. Furthermore, while going back, within the eOS Recovery, the Command Prompt windows showed something like “installation 0.” instead of the descripted “Script succeeded result was [1.000000]”, which as a beginner, is a bit confusing. Even if everything went well and I’m happy for it !

I guess this is a feature / bug of adb. One difficulty is that adb has to be able to work across many host PCs and many Android devices. The important thing is that the actual data was transferred successfully bur perhaps the exact “acknowledgement” return signals are not exactly interpreted.
A response including

something like “installation 0”

does include the UNIX concept that there was no error, but the longer wording on the install page details a set of responses to a script.

1 Like

Thanks for your answer !

Here’s a topic where you can bring this up to improve the documentation …

Thanks @AnotherElk. I’ve replied my points on your posted link :+1: