Switch from android s to t to get the 1.19.1 update?

I have a problem with the v1.9.1 update on my phone
About phone: FP3
/e/OS version: 1.17-s-20231111351092-dev-FP3
Android 12
Problem description: i do not receive anymore OTA update because I guess, the dev version has been moved to android t?
I can not figure out how to switch to the latest version. This was describe in a previous post when I had to switch from 1 to s but the documentation is not more available.

thank you in advance for your support

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

You might want to look at my own and @Loaders’ recent experience:


Worked for me, too, just now (as far as I can see, will test later) :+1: .

1 Like

Thank you so much! It worked perfectly as it is described here!

I made a local copy of theprocedure in case I need it in the future!

merci beaucoup!

1 Like

Just keep in mind there’s no guarantee a move to a new major Android version will work in the future in whatever way without wiping the phone in the process. It didn’t always work this way in the past, so we can really appreciate the times when it does :wink: .

Indeed, thank you for the information. I am clearly not an expert and this is why I am always amazed when something work!

Interesting, l’ll look at this solution. For the moment, I did a dirty flash from 1.17 S Dev to 1.19 S stable. But I miss the root solution… So I am willing to get the Dev version. Or can I flash magisk somehow on stable versions?

of course you can install the magisk app, patch the boot.img (or recovery.img) and flash it using TWRP or fastboot

how do I patch an .img for magisk, please?

1 Like

Fairphone | FP3+ | FP3 | previously on /e/OS 1.17-s-20231111351092-dev-FP3 | not rooted

Thank you @urs_lesse for the very straight-forward and comprehensive instruction including the download link. I can confirm that this worked for me as well in under ten minutes. :+1:


I did it now with this method (I always did the old method before), and it wasn’t as difficult as I thought. Thanks!