Teracube stuck in bootloader while flashing easy installer

Hi there,

I just got my new teracube 2e in the mail and im trying to flash e.OS on it, im a complete newbie to flashing software onto a phone but i have some technical experience. Should be a piece of cake with the easy installer, but im running into an issue with flashing the firmware, the installer & Phone always get stuck while rebooting into the bootloader.

I tried to start the bootloader manually, which works, but nothing changes but the position of the “=> FASTBOOT mode” text.
I downloaded and installed the newest dricer for the USB serial form teracube website.
I went into the recovery mode but just takes me to the standard recovery mode. like described here:

Here you see a screenshot of the easy installer and phone screen, not that it contains a lot of info.

Hi @Flolderauer welcome to the /e/ forum.

You might compare your experience with three reports of difficulties with Teracube and Easy Installer in the past month.

This might be a bug of some sort?

1 Like

Question 1:
What exactly happens on the phone at that stage?

The installer should reboot the phone into fastboot mode. Does that happen? Is it the same result like when you manually boot into fastboot mode?

Question 2:
Now, without executing the easy-installer, can you manually boot into fastmode mode with the USB cable connected and then press Windows Key + R, type “cmd” into the small window that appears and hit the enter key?
That gives you a command prompt. And there, please type "C:\Program Files\easy-installer\bin\adb\fastboot.exe" devices and hit the enter key again.
Do you get any output from that command? And if yes, which one?

One thing you can try as well: execute the editor (notepad) as administrator and edit the file C:\Program Files\easy-installer\bin\scripts\reboot-fastboot.bat

Change the first line

@echo off


@echo on

By that, the script to reboot into fastboot mode will print each line into the log before it gets executed.
That might give a better hint where exactly it hangs.

1 Like

Hi @aibd

Thanks for the advice, but all three topics are not really related to my problem.

Hey @Ingo_FP_Angel,

Thanks for your quick response and help.
I solved the first stage of my problems already, by useing a different computer and reinstalling the usb driver with the mediatek driver from here: Download Teracube 2E USB Driver for Windows.

So i continued with teh easy installer, it started flashing the image but after about 10secs reported an error something like “was unable to install” and the installation was unsucessfull.

the log says "error: device ‘2021111T2Exxxxxx’ not found ,obviously with my real serial number.
but if i check via command line enry you described, I get back my serial number and fastboot
eg. 2021111T2Exxxxxx fastboot

I tried starting the phone, it showed, that its in orange state and can’t be trusted an then just recovered the stock android.

I tried redoing the whole process, same result.

Maybe the full log can help here. See Howto troubleshoot issues with the easy-installer for the log location.

Thanks for your help @Ingo_FP_Angel,

Here is the last log file:


That log is really helpful :slight_smile:

The installer is able to download the image archive, unlock the bootloader, unpack the archive, but then fails as soon as it tries to flash the first partition.

That happens in line 127 of flash-scripts/windows/emerald-install-from-bootloader.bat · master · e / devices / Easy Installer · GitLab

The command there is

%FASTBOOT_PATH% -s %DEVICE_ID% flash %%partition_name[%%i]%% %%partition_image[%%i]%%

which gives the error

fastboot: error: cannot load '%partition_image[0]%': No such file or directory

I’m not an expert on windows CMD scripting, but my interpretation is that the variable name “partition_image[0]” gets passed to fastboot instead of the variable’s value "gz.img " defined at the top of the script.

Note: I’m looking at the latest version of the script which might not be the one used in the released installer package.

Don’t have much time right now, but at least I wanted to share the result of my log analysis.

Edit: although I can’t test it myself, it should work if the script was changed to

(for /L %%i in (0,1,10) do (
	setlocal enableDelayedExpansion
	%FASTBOOT_PATH% -s %DEVICE_ID% flash !partition_name[%%i]! !partition_image[%%i]!
	if errorLevel 1 ( exit /b !partition_error[%%i]! )
	timeout 1 >nul 2>&1
	call echo "Flashed %%partition_name[%%i]%% "

For some reason, variable substitution seems to be different for “echo” and other commands :confused:


Just as a cross reference %partition_image[0]% was also seen in the already linked thread Installation issue with Easy Installer for Teracube 2e.


FYI: I created an issue in the bugtracker


In principle people don’t need to wait for a fix when they edit the file C:\Program Files\easy-installer\bin\scripts\emerald-install-from-bootloader.bat manually with the text editor of their choice.

I just tried to do that, and the result is still the same.

I guess ill have to clear some time and redo this manually without the easy installer on the weekend.

Thanks for your help though, its really apprechiated!

1 Like

Ok, while the result may be “the same”, there surely must be a difference in the log, because all lines get printed before they get executed. Do you see the setlocal enableDelayedExpansion in the log?

Also, the relevant error should now read

fastboot: error: cannot load '!partition_image[0]!': No such file or directory

i.e. “!” instead of “%”.