The /e/OS Installer arrives!

In fact @Popescu , I’m surprised. At the same time, I wonder why you ignore rigeros facts and interpret my information as not “trustworthy answer”.

Of course, you are free to think what you like. But if you trust neither yourself nor others, you have two options: try it out according to the principle of “trial and error” or wait for weeks until all the facts are as you thought and hoped. Since you’ve already decided, there is no need for any further assistance from me.

You didn’t understand my comment. I never said that the informations you were giving were not trustworthy. I was only answering Piero’s comment telling me to buy a S9 from a “basic user that would have been too afraid to update his S9”. So I was only saying that it would be difficult to obtain a trustworthy information about that before actually buying it. It actually surprises me that you took it against you since I’ve been grateful for your explanations.

From my point of view, it appears to be so difficult to have the right conditions to be able to successfully install /e/ android 8 on a S9 stock android 9, needing an exact security patch (an information nearly impossible to obtain from a basic user), that it’s as good as not possible since I don’t feel like playing lottery with that amount of money.

»You didn’t understand my comment.« or your comment is imprecisely formulated and thus leads to misunderstandings. It is a favorite pastime of many people to blame others for their own dissatisfaction. Become active, take responsibility and improve their situation.

The “right prerequisites” to successfully run /e/ Android 8 on an S9 stock Android 9 are given, as countless successful installations prove.

Buy a deGoogled /e/ phone from the or a used one from privat with preinstalled /e/ OS and you have no risks when changing the operating system.

Advertise a purchase request in the category Sell / Swap with concrete, clear requirements and how much you are willing to pay for it.

If you are really interested by the /e/project

It is imprecisely formulated and yet you immediately take it against you without a single element refering to you. That’s quite an irrational reaction to be honest.

The right prerequisites to succesfully install /e/ android 8 on an S9 stock Android 9 are given and particularly difficult to meet since it is necessary to have the exact security patch required.

Unfortunately the S9 from their website is still too expensive for me. It is normal to find them more expensive than market price to support the project but the difference is too important for me since this refurbished phone’s price is the same as new from the store.

I’d gladly advertise a purchase request but most answers wouldn’t be trustworthy since I’d have to request an exact security patch and the vast majority wouldn’t even know what it’s about. That’d be too risky for me.

I feel sorry that you judge necessary to be salty in your answers as if me stating the mere reality would threaten the whole project you’re working on. Going on about how it is perfectly possible to achieve it without taking in account the reality of most people interested in your project won’t help to make it user firendly and adopted in larger scales. That’s a pity because /e/ is really interesting. Since I feel anger in your answers and you keep your mind closed, I don’t think it’s necessary to go on with this exchange. Still, thank you for your answers.

Thanks a lot for this information, yes I’m genuinely interested in this project. Unfortunately the S9+ is too big for me.

My mind is wide awake and I know what I want and what I’m doing.

Now that the S9+ is suddenly too big for you - tell me a concrete price you are willing to invest in a /e/ phone and I guarantee you the worldwide delivery of a Samsung phone with current /e/ OS ROM pre-installed within 24 hours (day of shipment).

Archje is personally very involved in welcoming and accompanying new users. He takes time and does research in order to provide clear, precise and documented answers.

For 5 months, you have been asking questions on the forum, (s7 then s9) without taking the step. Archje and other users answer you patiently.

Here is my last proposal if you think that the Galaxy s9 is too expensive and not compatible enough, i advise you to buy a Galaxy s4 or s5 for 50€ or 100€, you will be able to try /e/OS without any particular complications and at a lower cost.

Translated with the help of (free version)

1 Like

The Galaxy S4 GT-I9505 “jfltexx” or S5 SM-G900F “klte” are very robust devices and have a future, because they are officially supported by the LineageOS Project.

For the S4 even LineageOS 17.1 (Android 10) is already available and runs amazingly fast.

The S5 is currently supported with weekly LOS 16.0 (9-pie) updates and will get LineageOS 17.1 in the near future, because the head developer “haggertk” is working hard on it.

So /e/ Built Team can still generate a /e/ fork with known effort.

There is nothing sudden in that, I’ve always hated big phones.

That’s a strong proposition. I’m thankful for you to still try to find a solution despite the difficulties. It all depends and the specs and state of the phone.
I’m looking for a phone in good state (no scratch on the screen and still a good battery life) with at least 4gb or maybe 3gb of memory and not bigger than a S9. For a /e/ second-hand phone comparable to the S9 specs, I’d gladly pay 330 euros and 160 for something comparable to a S7. It doesn’t have to be a Samsung.

I know that he is very dedicated to helping and informing and I admire that to be honest.
Still the possibilities weren’t satisfying for me.
Thank you for this suggestion but those are quite old phones and second-hand phones of that age would probably have some state problems and low specs. So I’m not interested in these options. If I can’t find a suitable option, I’ll just wait for /e/ S7’s version to be migrated to android 8 and use the easy installer.

Thank you for your answers

I’ve outsourced my offer to sell / swaparea and expanded it to Position⁴.

1 Like

Thank you very much for taking all that time to answer me. The A5 and S8 look interesting but what would be their prices?

I have tried the easy-installer. For a long time, I could not get it to detect my phone. I was getting stuck on the screen “Looking for your device”.

After searching around and some trial and error, I finally managed to get it to detect the phone and to proceed to downloading the necessary files.

I went back and forth to replicate it, to confirm what the solution was.

Not sure if that is specific to my setup (using easy-installer 0.8.3-beta on Ubuntu 18.04, connecting to a Galaxy S7 running Android 8.0.0).

I had to combine three things I had failed to understand I had to do (I may have missed some info on that?).

  1. on the desktop, I had to manually give USB access to the easy-installer.

  2. on the phone, I had to enable the “USB debugging mode”.

  3. on the phone, when the easy-installer launched “Looking for your device”, I had to respond to a pop-up to confirm that I allowed USB debugging from my desktop

Give USB access to the easy-installer

On the desktop, I had to manually give USB access to the easy-installer, and reboot after doing so (for some reason it would not work until had done a reboot).

Once I had installed the easy-installer, I had to do:
sudo snap connect easy-installer:raw-usb
sudo reboot

Maybe this access is normally granted automatically, but for some reason it did not happen on my ubuntu 18.04?

Enable USB debugging

The action “Enable the Developer mode (Part 1)”, with its 3 steps, worked fine and resulted in the Developer mode being enabled (or rather, actually, in my case, telling me that it was already enabled).

The action “Enable the Developer mode (Part 2)”, again with 3 steps, I found a bit confusing. First about what it was meant to do, since the Developer mode had already been enabled by the previous action. So I understood the objective of the action being to do whatever would be the result of performing the action’s third and last step “Tapping on Android debugging”. First problem, searching for “debug” did not return any “Android debugging” entry I could tap. It did return a “USB debugging” entry, but tapping it was only taking me to the list of “Developer options” settings and showing me the current setting for “USB debugging”, but not actually changing any settings.

What I actually ended up doing in lieu of this “Enable the Developer mode (Part 2)” is more like:

  • Enable USB debugging
    • Open the settings menu again
    • Type “Debug” in search bar
    • Tap on “USB debugging” search result
    • Enable/allow “USB debugging”

Allow USB debugging access from my desktop

When the easy-installer launched “Looking for your device”, a pop-up appeared on the phone, but I had missed it because it did not stay very long. It asked to confirm that I allowed USB debugging from the specific desktop the easy-installer was “calling from”. I needed to see it and to tap OK for the easy-installer to find and recognise the phone.

If the pop-up had disappeared, I could make it reappear by disabling and re-enabling USB debugging in “Developer options” settings.

Maybe some we could have some warning about this step on the “Looking for your device” screen?


Hope this helps. Happy to do further testing, or provide documented test report with screenshots.

Now, once I got past these hurdles, the installation failed… :unamused:

It could be linked to my device and Android build. Possibly related to S7 install trouble. But I will look into that another day.


My host machine: Kubuntu 20.04 LTS 64-bit. My Samsung Galaxy S7 - “herolte” wasn’t recognized immediately (see also Fig. 11). Sometime I will try the tool again to be surprised by a positive result.

Thanks for the detailed feedback @AntoineGuichard pl check again when free and let us know if you are still facing issues or if the installation completed succesfully. I believe some of the warnings you mentioned do appear on the screens . May be in our future versions we will make them appear more often.

Thanks @archje.

My Samsung Galaxy S7 is a “herolte” too as far as I understand (SM-G930F, Android 8.0.0, Baseband G930FXXS6ESI6, Build R16NW.G930FXXS6ESI4).

The easy-installer detects the phone, shows the message “Your SM_G930F is compatible with /e/ OS” and downloads source files,, twrp-3.2.3-0-herolte.img, and twrp-3.2.3-0-herolte.img.sha256sum.

Then it shows the screen “Connect device and start download mode”

When I get the blue screen on the phone and press “Volume up” to access the download mode then:

On the phone side:

  • A blue-green screen shows “Downloading…”, with at the top left in very small letters I cannot guarantee to read entirely correctly:
    ODIN Mode
    Download speed: fast
    Product name: SM-G930F
    Current binary: Samsung official
    System status: Official
    FRP lock: off
    Secure download: enabled
    Warranty void: 0 (0x000)
    RP S0REV: 0:6 K:4 S:5

On the easy-installer side:

  • Shows step “Unlock OEM”, then

  • Very briefly shows again the screen “Connect device and start download mode”, then

  • Very briefly shows a screen “Recovery installation”, then

  • Shows a screen “the installation encountered an error”, with options “Try again” and “Send [log?] to support”

Trying again restarts the loop.

I sent the log to Support.


When I reboot the phone, it restarts Android 8.0.0. So nothing erased, all good.

I will try again tonight, after looking around for possible relevant info on the forum :slight_smile:

Have a good day

1 Like

@AntoineGuichard, thanks for your detailed feedback. They’re important!

If “herolte” boots again with stockROM Android 8.0.0 after this whole procedure, then TeamWin - TWRP Recovery wasn’t installed - and only the original Android Recovery is available.

After flashing TWRP must immediately reboot into TWRP again, so that TWRP remains permanently in the device as a custom recovery. If the partitions /system and /data aren’t deleted, /e/ OS ROM will not work properly.

Whether the script considers all this, I can not comment at this moment.

See you next time.

Thanks @archje

It looks like I have, at least, a problem with the easy-installer not being able to write to the phone.

libusb: error [_get_usbfs_fd] libusb couldn't open USB device /dev/bus/usb/006/121: Permission denied
libusb: error [_get_usbfs_fd] libusb requires write access to USB device nodes.

I had always launched the easy-installer via my GUI. In Kubuntu: open KMenu, start typing easy-in… then select the program to launch it.

I discovered that if launched the easy-installer directly from the command line (in BASH console, type $ easy-installer), the console continued to output information about the commands and steps.

So I could have, side by side (see screenshot below): (1) the window running the easy-installer’s graphical user interface; and (2) the BASH console showing commands and/or steps followed.

More informative and useful for debugging :slight_smile:

Using that method, I ran a new attempt at installation, which failed exactly as before.

What the console showed, from when the screen “Downloading /e/OS and necessary files” showed “Download is complete, you are now ready to install /e/OS on your phone!”, just before clicking on continue:

execAndReadOutput() : /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/
Splitted command: /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/ /snap/easy-installer/6/easy-installer-linux-x64/bin/
Process started

Heimdall path: /snap/easy-installer/6/easy-installer-linux-x64/bin/heimdall
Update UI for/snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/

Download mode detected
execAndReadOutput() : /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/
Splitted command: /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/ /snap/easy-installer/6/easy-installer-linux-x64/bin/
Update UI for/snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/
Process started
averageTime is: 8

Heimdall path: /snap/easy-installer/6/easy-installer-linux-x64/bin/heimdall

libusb: error [_get_usbfs_fd] libusb couldn't open USB device /dev/bus/usb/006/121: Permission denied

libusb: error [_get_usbfs_fd] libusb requires write access to USB device nodes.

ERROR: Failed to access device. libusb error: -3

OEM unlocked
execAndReadOutput() : /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/
Splitted command: /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/ /snap/easy-installer/6/easy-installer-linux-x64/bin/
Process started

Heimdall path: /snap/easy-installer/6/easy-installer-linux-x64/bin/heimdall
Update UI for/snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/

Download mode detected
execAndReadOutput() : /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/
Splitted command: /snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/ /home/antoine/snap/easy-installer/common/sources/twrp-3.2.3-0-herolte.img /snap/easy-installer/6/easy-installer-linux-x64/bin/
Update UI for/snap/easy-installer/6/easy-installer-linux-x64/bin/scripts/
Process started
averageTime is: 6

Heimdall path: /snap/easy-installer/6/easy-installer-linux-x64/bin/heimdall

Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is


If you appreciate this software and you would like to support future

development please consider donating:

Initialising connection...

Detecting device...

libusb: error [_get_usbfs_fd] libusb couldn't open USB device /dev/bus/usb/006/121: Permission denied

libusb: error [_get_usbfs_fd] libusb requires write access to USB device nodes.

ERROR: Failed to access device. libusb error: -3
Stage is closing

Not too sure where to go from there.

You can try to run the tool as root, type sudo for the command you used before. This should not the way it should run, just to see if it works.