[UNOFFICIAL BUILD] Pi/e/ GSI for Mi MaX3 (nitrogen)

The ‘normal’ rom wasn’t working. So I have tried to flash eGSI on nitrogen. And … it’s running.

This way was working for me:

  1. Treble Info has shown that I do have an arm64 a/b device. But I have to flash the a_only GSI !!!
  2. And after flashing the GSI I have to change to vbmeta.img. You will find the image here
    thanks to Phh for this tip and command
  3. Download e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img.zip
  4. extract this zip. It will generate a 2GB img file
  5. download vbmeta.img
  6. boot your device in recovery and FORMAT data
  7. boot your device in fastboot mode (bootloader)
  8. run theses commands in terminal
    a) fastboot erase system
    b) fastboot flash system e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img
    c) fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    d) fastboot reboot

and now your system show boot into eOS … i hope

my terminal log you will find here for comparing.

Good luck

1 Like

I only have a Xiaomi Redmi Note 4 - “mido” running, but thanks for your construction work on Karfreitag.

1 Like

Build still untested?

yes. the shipment of my device was canceled. So I can’t test it anymore.

Damn, this seems to be the only build that finally supports a phablet.
I have a Mi Max 3 as my second device but I’m afraid of bricking it. I have never flashed a custom rom before.

No risc no fun :wink:

Well, just tried on my old Moto G4 and I already cant even go to step 1.
I activated USB debugging, plugged my phone to a computer, used the command adb reboot bootloader and that’s it. Nothing happens.

YOU HAVE TRIED ON A MOTO G4!!! OHHH NOOOOO. I hope you haven’t bricked your device for ever.
This ROM is for XIAOMI MI MAX3.

Never try flashing a rom if it isn’t 100% designed for your device !!!

No no, I mean the official build for the G4, not this one here. Just for a test.
But I can’t even flash the rom when no command works.

OK, better open a extra post for that, pls

check if you’ve installed the platform tools.
just check with the command “adb devices”
and see what happens.