USB access on SD card

I have a brand new Fairphone 3 with the preinstalled /e/ from August 2020.

Configuring it I achieved a lot. What I couldn’t manage until now is USB access from a PC to the external SD card in my mobile. I even can’t always access the SD card from inside, I mean using apps. Some apps work (Files, Total Commander), some do not (the Camera app can’t save the images on the SD card, I have also an FTP server app which also can’t - why???).

What I saw is: the app permissions for accessing the SD card (read and write) are mostly gray, why? This is even the case for apps which have read and write access (for instance the Total Commander file manager).

I have about 30GB of files I want to be located on the SD card (mostly music). What I could do is connect the mobile using a cable to a Windows PC, access the popping up USB drive named FP3 (P2P mode only, I read this in another thread) and pump all the files onto the device memory. Then I used the file manager on the mobile to move all that stuff onto the SD card. Is this really the intended way? What if I don’t have not enough space on the device memory?

On my Linux machine I could never get any working USB connection. There’s never a usable /dev/sdb1 or /dev/sdc1 I would need to mount it somewhere. This brings up a new question: what file system is on the SD card? I formatted it new using the mobile device because in the first moment the Files app said “Not usable”. A Linux machine expects exFAT (or not?).

I used Blackberry 10 devices for a long time. On such devices I could easily plug in the cable and pump everything in both directions, on Windows and on Linux, this was never a problem at all. (But while the cable was plugged in the device himself couldn’t access the SD card.)

Now it seems indeed that I couldn’t even charge the mobile using a cable plugged in into a PC. Why is this all so complicated???

Hello @irrlicht ,
Welcome to the forum!
I cannot answer to all points but only share my experience:
With a FP3 and pre installed /e/, I can store my Open Camera (Camera) photos on the SD Card.
In Camera > Settings > More camera controls > enable “Use Storage Access Framework” and there choose a folder in your SD Card.
I can access these photos via USB cable from a Windows computer.
Just beware of what might happen if you uninstall Open Camera. I don’t know if the folder and files will be removed or not.
see Open Camera FAQ here.

1 Like

Indeed, “Use storage access framework” does what the above location selection dialog does not. If I use there a directory on the SD card it says “can’t write in that folder” and resets it to a directory on the device memory. Probably this depends from “Use storage access framework”.

(But who needs these two options? And for what???)

A direct access from a Windows-PC to the SD card is still not possible. The USB drive on Windows is always a directory on the device memory.

I can charge my Fairphone 3 just fine on USB ports, and I can access my SD card just fine from the Windows PCs I can get my hands on.

This is not normal.
If it was me, I would try a different cable and a different port.

Apart from that, heavy usage of the phone while charging could prevent charging because the net gain of charging the battery while using up the battery could be close to zero. But I think you would notice this, so it seems unlikely.

Since the phone is new, I think we can disregard dust or lint in the port.

I don’t know what P2P is supposed to mean in this context, probably we are talking about the PTP mode for the USB connection. This would be intended for pictures. I read here and there that people still use that, but I’m not sure why (meaning I never had a use case for that, it could be perfectly fine for some purpose I simply never came across).

The usual connection mode for file transfer is MTP.
Normally, once you connect the phone to a computer, there should be a notification informing you that the phone is charging. If you tap the notification, you can set a different mode for the USB connection, first on the “Use USB for” list should be “File transfer” now … this is the MTP mode.
Earlier Android versions listed it as such, but it doesn’t matter much how it’s called.

MTP has to be set up correctly in the computer OS, too. This works automatically and seamlessly for most people, but stuff can get in the way.
I can’t say much about Linux, but I have seen driver trouble preventing MTP to work correctly on Windows, here’s a generic driver repair.

Normally it isn’t, but this of course doesn’t help you.
What you describe overall could also be caused by a malfunctioning SD card or connection trouble.
Perhaps try to reseat the card in the slot and let the phone format it again. Make sure you let the phone handle it as external storage.

Yes, PTP, not P2P.

Why? Because it’s the only mode that does something, all the others lead to nothing, the plugged in device is not visible from the PC, neither from Windows nor from Linux. I tried two data cables and three PCs until now.

I will see if the link for driver repair brings something (question: what to do on Linux? At home I have Linux machines only.)

Charging does work in most cases now but I had indeed at least one case where it didn’t. I know this because I was low on battery and watched what happened, and the accu was still going down while the cable was plugged in.

Hey, I checked the USB settings (drivers) in the Device Manager in the Control Panel of my Windows 10 PC. I pressed also “Search for new hardware”. It didn’t bring up any visible change but …

… just now I plugged in the cable, switched on “File transfer” and have indeed access to the internal device memory and the SD card for the first time, read and write. I don’t know why, or what has changed (or if anything has changed at all) but now it works as I always expected.

Will check this on my Linux machine this afternoon.

On Linux you can install a package named android-file-transfer which opens a GUI to upload and download files on both the device memory and the external SD card. This seems to be a usable solution. There’s also a package named mtpfs.

But ordinary mounting a /dev/* device is still not successful. When the cable is plugged into the Linux laptop and I switch to File transfer mode a new device appears on Linux named /dev/libmtp-2-6. Indeed it’s a symbolic link to /dev/bus/usb/002/016. But when I try to mount it somewhere the mount command says /dev/libmtp-2-6 is not a block device.

This is in analogy to Windows where also no ordinary USB drive appears (like for instance a plugged in USB stick). In Windows it’s called a “portable device” and you cannot give it a drive letter.

I will check what happens on my mint box.

I remember some troubles with a stock ROM in the past. But can’t remember what or which.

It is mounted as


where I find external and internal memories

when you specify file transfer on the phone

On the contrary, whenyou pick PTP,
it is mounted on


I hope this helps you. Let me know if you want me to test some other things.

It is mounted as


But who does the mount? And how? Do you have any Desktop Environment running? On a plain Linux console no automatic process does mount it during plugin.

No, I never attempted through the terminal.
I Struggled for some time then I gave up.

As far as I remember mtpfs was the key library.

Linux 19.3 Cinnamon


Cinnamon, MATE or Xfce are default desktops available on Mint (3 different ISOs)…