Using microG Exposure Notification version and updating to 0.14-o, 0.14-p or 0.14-q? Read the release notes!

If you have the microG Exposure Notification version installed and plan to update to the newly released 0.14-p or 0.14-q, please carefully read the release notes:

"microG EN update

The new microG version add some improvement in the Exposure Notification API. Unfortunately, the update we shared on Apps doesn’t apply automatically. To apply it manually, you have to:

1. Open Apps
2. In Search tab, search for microg
3. Tap on Update

If you apply the v0.14 update before having update microG, microG EN will be uninstalled. In case it happens, no worry:

1. From your device, download and install manually microG EN version:

/dev devices
/stable devices

Be sure we will do our best to avoid this inconvenience in the future!"


This means you have to apply the microG update in Apps before updating the OS, if you don’t want to manually install the APK afterwards.
(Alternatively you can try to force stop Apps and clear its storage in the Settings, then search for microg in Apps and install the Exposure Notification version again. Tested for you by somebody who read the notes but only got what they meant afterwards, well it’s late :innocent: .)

8 Likes

Thanks for posting this @AnotherElk
…despite our best efforts, at times the transition from one build to another does not work seamlessly. I would like to assure the users that the development team is tasked to work on removing these glitches in future builds.

1 Like

I didn’t find microG in the search tab. At my Fairphone it is in a different place in the app ‘Apps’
1 Open Apps
2 Go to Catogory (to the right of the ‘home’ icon on the bottom of the screen)
3 Go to System apps
4 Now you can find microG Exposure …

1 Like

It will not be auto-suggested while you type the name, but once you really start the search it should be there.
But you’re right, it’s in “System apps”, too … not to confuse with “System” there.

Somehow it didn’t show in the search tab. It still doesn’t.
I search for micro and I get all kinds of microsoft …
I search for microg and I get MicroGuide.
I search for micro g and I get Micro Golf

On my FairPhone2 with /e/ 0.13, I tried several times to update microG as recommended in the release notes:

  • Found the microG EN app in Apps (however app details cannot be opened)
  • tapped “Install” -> Apps crashed (note: it was “Install” (“Installieren” in German) rather than “Update”
  • repeated these steps -> Apps always crashes
  • force-stopped Apps and erased its storage
  • repeated the steps again -> Apps still crashed several times
  • finally, “Install” did not crash Apps, but the installation seems to hang without any indication of progress.

Can I install the microG update in a different way (for instance via F-Droid)?

Ingolf

You could just do the upgrade from v0.13 to v0.14 and then follow the instructions from the release notes/first post.
That would be the recommended “different way” if updating microG EN via Apps does not work (or simply wasn’t done before the update).

But as you said “note: it was “Install” (“Installieren” in German) rather than “Update””, it sounds as if you didn’t have microG EN installed earlier. In that case, if you don’t have it installed now it can’t get uninstalled during the update, so you’d be fine. Only people who already had it installed should update the system app before the OS update.

2 Likes

@Ingo_FP_Angel Thanks for the explanation.

Indeed, the microG settings report “…-dirty-noen”. However, I have been using the Corona Contact Tracing Germany app – apparently it did work. Would I keep its contact history when updating to 0.14?

Kind regards
Ingolf

This App has its own implementation of the Exposure Notification framework built-in for use when the microG implementation isn’t available on the phone. So this App is supposed to work even if the “noen” version of microG is installed.

But the own implementation only works if it doesn’t find an installed microG with EN. But in this case where microG was without EN, all the data should be kept in the app.

Just for the record: Installing EN afterwards seems to keep the trackings as well (I had to install it after the update even though I updated EN via Apss before).

Now I am completely confused…

@AnotherElk yes, I had been aware of CCTG being able to work with its built-in EN support. But…

Following the advice in the README (first FAQ topic of https://codeberg.org/corona-contact-tracing-germany/cwa-android/src/branch/main/README.md; linking to that web server not allowed here) to check the ENF settings, I am directed to the system microG settings; I had expected to see the settings for the ENF embedded in CCTG. (Remember: the system microG settings report Version 0.2.14.204215-dirty-noen).

The CWA Companion, however, needs to be used in “CCTG mode” to report statistics.

@chogo Do you know of any “official” statement with respect to keeping the tracking history when upgrading from a system w/o ENF to one with ENF?

Kind regards
Ingolf

Tracking from a system w/o ENF to one with ENF wont work I think. I did the tracking on a system with ENF and it was only shortly not available.

The instructions and APK download for 0.14-p and 0.14-q have been confirmed to work for 0.14-o, too, although release notes for 0.14-o seem to be missing. Topic title edited.

I tested this alternative to reinstall MicroG EN on my S9 phone, and it worked perfectly.

1 Like

+1 This method worked for me. Only had to clear cache did not clear storage/user data.

2 Likes

I did not have microG EN (I think, at least Coronalert app complained about it; installed /e/ from here on my moto G5).

However try as I may, stopping Apps, clearing storage, Apps keeps crashing … :frowning:

Any ideas ?

Thanks

There is a link for direct download at bottom of https://gitlab.e.foundation/e/os/releases/-/releases/v0.14-q (for you, it’s the “/dev” link).
Could you please try it ?

Apps app crashing seems quite common nowadays :frowning:

Hi,

thanks for the reply:

I downloaded the /dev and tried to install it (after allowing installing apk’s from the browser source) but it comes back with “microG Service Core \n App not installed”. :confounded:

Sorry it didn’t work :frowning:

Could you please check you have MicroG 0.2.17.x installed ?

Yes that seems to be the case ‘microG Services Core’ (small M) version 0.2.17.204714-117 (9a3d582)-noen