When will we be able to flash /e/ android 10 on S9 with the easy installer?

When will we be able to flash /e/ android 10 on galaxy S9 with the easy installer? I would like to have an ETA please.

The upgrade of the Easy Installer to handle Q is not done as yet. It works for the FP3 but not for other supported devices. There was a suggestion to get the Easy Installer to select the build type. At present it only installs the stable builds. The suggestion was to give the Easy Installer user the ability to install dev and stable /e/ builds. Will update if this gets planned or if we have an ETA.
The stable Q versions are not yet released for most devices. We will update when they will be released.


Thank you for your answer but it’s not very clear. I’ve read somewhere else that the stable version of Q for the S9 still hasn’t been released.
When will it be released so that we will be able to install it with the easy installer?

Added in my response above

@Manoj Also very keen for this hence +1.

I managed to borrow a Win Laptop, used Odin to flash my S9+ from A8.1 to A10, then used my Mac Booted on Ubuntu USB to run Easy Installer which now shows I am back on A 8.1 :frowning: So now I dont know if A10 is still the underlying OS with eOS reporting it as A8.1 or if Easy Installer actually wiped the A10 update I did. Just want to get to A10 + eOS 10. Rather a challenge without the right tools.

I don’t know how we can show our appreciation for eOS and all you and the team do, but its VERY APPRECIATED!



After flashing to A10 follow the instructions on this post and you should be good to go

if you don’t still have access to the windows laptop you borrowed you should be able to do all the odin stuff with heimdall on your mac

Hi deklemoli
Thanks for your reply. I had not found that post before, so your post was good food for thought.

After thinking about your post, I realised I could install “Bootcamp” on my MacBook Pro, which then let me install WIN 10, which I owned a licence for from years ago when I ran WIN 10 on my Mac with Parallels (virtual machine). I had read using Parallels+WIN was a BAD IDEA for flashing phones. But thanks to your post, it prompted the thought to install WIN on BootCamp, so now I have a WIN laptop and can run Odin. However…

Now with WIN 10 on my Mac in BootCamp, I ran Odin and all appeared fine, as it could see my S9+. HOWEVER… when I tried to flash the S9+ with A10 it failed, and I then remembered I had turned on ENCRYPT once I had eOS running. After all, we all want our phones private AND secure right? So now I have to work out HOW to remove (wipe?) the encryption off the phone so I can then flash with A10, then install eOS again…

Kind regards to all who are helping us newbies, and hope these posts help others avoid some of my mistakes :slight_smile:


Odin has nothing against encryption. Stock Android 10 itself is set to encryption at the factory.

What error message did Odin display?

It had some small text something like: “Bootloader Check Failed”. Actually, Odin stopped at “Recovery” I think it was, and on the phone screen in small text, it added the line about “Bootloader Check Failed”…


David, that’s a hint that you tried to flash a wrong stock android 10 version

What bootloader version is on your S9?
(see S9 > software info > Build number QP1A …G960FXX… or Baseband version G960FXX… )

Which version of Stock Android 10 did you want to flash?

Hi @SuzieQ, thanks for trying to help :slight_smile:

I am a little concerned I may be in trouble with the phone. Perhaps I should make sure you know where the phone is at as of yesterday, BEFORE I received your posts.

Summary of my Actions:

  1. Purchased New S9+ with A8.1
  2. Flashed with Easy Loader = A8.1 + eOS8 and + TWRP = all was well.
    Wanted to get phone to A10…
  3. Used TWRP 3.2.3-0 to do a backup but I can set up phone apps again manually.
  4. I downloaded Stock A10 from samfrew.com file For Australia / Telstra provider:
  5. Used Odin to Flash A10 = Success
    Read all over the forum to work out how to install eOS Q/10 but could not work out how as I am not very good with terminal. I gave up and decided to go back to eOS 8, so…
  6. Ran Easy Installer = Success = eOS / A 8.1 + Encrypted Phone
    Then received deklemoli post and thought I would try again… so read all over the forum to work out how to remove encryption.
  7. Used TWRP to Wipe > Advanced wipe : select all and wipe. Wipe > Format Data : type yes and format.
  8. Tried to flash A10 with Odin and it STOPS at displaying in Odin “Recovery” as last action, and on phone screen it has something like: sw rev. check fail (bootloader) device

The phone now has NO os on it. Just TWRP, so not sure how to check which bootloader is on it now.

I WILL NOT do any more actions on the phone until you advise, so I don’t make it worse, assuming I have not already killed the phone :frowning:

Thanks very much Suzie…

Between those two steps, you have to reboot the device into recovery mode
It’s noticed on the device screen when you format /data partition, you have to reboot in recovery mode before using the partition

Installing /e/ need this partition to be ready for use

@piero Hi Piero, thanks for that reply, but I just tried that again with a reboot to recovery between and it has NOT changed anything for me… still have the same error message…


Excellent David,
your explanations are comprehensively informative. It gives me a good picture of the situation. Still, your problem is a mystery to me.

Something must have happened to the bootloader between the first successful flash of stock Android 10 TEL-G965FXXSDFTL1 and the second failed one with Odin, which neither of us know at the moment.

I can’t write down all my thoughts now. It would take too much time and space. Therefore my suggestion. Let’s try one step at a time. If I were you, I would:

  1. Copy recovery-e-0.13-q-2021012097133-dev-star2lte.img to a SD card and insert it into the S9.

  2. Now boot the S9 into TWRP, “Install” recovery-e-0.13-q-2021012097133-dev-star2lte.img to ‘Recovery’. Immediately verify with “Reboot to Recovery”.

  3. Turn off S9 and reboot in Samsung ‘Download Mode’. Connect to the PC via USB cable and flash the stock Android 10 with Odin3.

Even if this procedure fails, your S9 will not be damaged. Let us know what happens. Let’s go!

I was misguided by the thread title. Of course, the files must be used for the S9+. I have edited them.

Thank you so much SuzieQ… I will try it now :slight_smile:

Hi again… umm… respectfully, is this the correct img… I have a S9 PLUS not an S9… ?

Just checking… :slight_smile:

I was misguided by the thread title. Of course, all files must be used for your S9plus. I 've edited them.

Hi S…

EDIT: Cancle this post, I have now clicked on “install image” button and can see file…

I have D/loaded the file, put on microSD, inserted into phone, booted into TWRP, clicked on INSTALL, selected storage of microSD, but I DONT see the file there… should it be visible with its real long filename?

“… should it be visible with its real long filename?”
Yes, please switch in TWRP from ‘Install’ ZIP to ‘Install’ IMG.
When the .IMG file is visible, tap on it and install to RECOVERY.

ok… I have now COMPLETED your suggestions… the phone flashed with the new eOS Recovery, etc… I immediately rebooted as you instructed… I then used Odin to flash A10… BUT… it still stopped at the recovery section AND had the same error message as before…

QUESTION: Does it matter what version of Odin I am using… ie a A10 friendly one or… ? I am using 3.14