Android Auto with /e/?

Hi everyone,

Is it possible to use an /e/ Smartphone with Android Auto?
I wondered, if /e/ supports Android Auto (or can be made doing it), but I did not find a clear answer to that in the forum. The tendency is however negative (see e.g., here: /e/ and Android Auto?)
Making Android Auto work would be a big benefit for some of us, you could control apps like GMaps or Spotify directly from your car. (I know that using these apps goes partly against the idea behind /e/ and is not the best option for some of us, but let’s leave out that discussion here!)

Is MicroG the Crux of the Problem?
It seems to be that the Problem is related to MicroG, which does not support Android Auto at all (see here: Implementation Status · microg/GmsCore Wiki · GitHub)
However, there seem to be ways of overcoming this (see here: microG + Android Auto fully working | Page 2 | XDA Forums), but they require flashing (i.e., installing from scratch) /e/ and I’m not sure if this will really help. Can someone explain to me in easy words what is missing in MicroG to support Android Auto? Is it realistic that we will see this in the near future?

My Attempts
When I tried to connect via Android Auto, I got the following error message: “Android Open Automotive Protocoll - no Apps installed for this USB-device. More information under http://www.android.com” (roughly translated from German: keine installierten Apps für dieses USB-Zubehör. Weitere Informationen unter http://www.android.com).

For that, I did install the Android Auto App (as it is necessary for < Android 10). I’m using a Fairphone 3 running /e/OS 0.18 20210815130098 (Android 9).
Are chances higher to get it running when upgrading to the /e/-Version of Android 10 or 11? From Android 10 on, it seems that the Android Auto functions are more built-in, as you don’t need to download the App for it.

Would the chances be higher to get MirrorLink running?

1 Like

Android auto does not work with microG

And yet according to the linked thread, it seems is does work! Or at least it can be made to work, with minimal tinkering :slight_smile:

I thought I would miss Android Auto when I jumped into /e/ with both feet. For the most part, I don’t. Voice to text never worked very well for me anyway, I can operate music and podcasts (mostly) through Bluetooth, and I just have to set the map up before I start driving. It’s a challenge, but I’ve found through my /e/ journey that for the most part, I can do without (which has been my experience with many apps I thought I “needed”)

3 Likes

Come on…maybe for you and me…but not for 90% of the users…
This is more then install a apk from outside a store.
One change in one bit and bammm, start thinking an trying again

1 Like

But you only see the map on your smartphone display, right? Or is there any other solution?

The map is on my smartphone display, I use one of those cupholder cellphone things to hold it where it can be viewed. The music and phone is controlled through the car stereo. I admit it’s not as elegant a solution as AA, and I basically have to have my route planned out in advance since I can’t use voice commands to “audible.” It was an adjustment but it gets the job done.

1 Like

So, this is the first Post. Yesterday I took my old Mi8 and flashed /e/ via OrangeFox on it. Was curious about the Operating System and wanted to try it. Afterwards I flashed Android Auto Application (from NikGapps) via Orangefox, due to the Fact that my Car complained that Android Auto has to be implemented on a System Level instead of Downloading the App through Aurora Store. After the Initial Setup of the Phone, I downloaded the Google App, Google Maps and Google Speech Services. I did not log into my Google Account using any of the Apps. I was then able to connect my Mi8 to my Car with Android Auto via USB Cable (haven’t tested wireless Connection atm). Navigation via Google Maps worked like a Treat. To get Plexamp (which I use for Music streaming) working, I had to enable “insecure Sources” in Android Auto via the Developer Settings (Multiple Tap on Version Number in AA). The following does not work :

  • Plexamp does not show me the whole Library of my Music. Using it without AA show whole Library. This is somehow strange …
  • Jellyfin (which I setup for testing) shows me Recent played Items, but will not start the Music streaming → Strange again …

Another Thing which bugs me is the Fact that the “Homeassistant App” isn’t able to locate my Position right. But this is another Problem…

3 Likes

Not exactly what you are looking for. But I thought I would mention that the Amazon Echo Auto + Alexa app does work on /e/OS sans any google services. Allowing for hands free navigation, hands free music, etc in the car.

It doesn’t solve the display issue. (I use a magnetic phone mount in my car.)

And of course there are obviously known privacy concerns with Amazon.

Just an Update. I found out that my Library isn’t fully revealed until due to the Fact that the Car is moving. If I stop and reopen the Library it is fully there.

Just an Update. I took my Poco F3 and flashed the latest 0.23 dev Build onto it. I noticed that Android Auto using NikGapps AddOns isn’t flashable anymore due to the Fact that the System Partition has no available Space on it. This is exactly the same when flashing my Mi8 again. Anyone else encountered this “Problem”? Tried fixing Partition with TWRP but didn’t help. PocoF3 has 128GB of Storage Space, so it should be some space availabe. Don’t know about the Partition Layout.

1 Like

Is there, perhaps, some open implementation of android auto? While the NikGapps sounds OK, it still requires g maps, g speech and g search on the phone, which sort of defeats the purpose of having /e/ in the first place…

1 Like

I know of no solution, but I think that this is generally possible.

Gmaps can be replaced by a different navigation app (I know of Here WeGo, TomTom, and Waze). Speech is not needed at all (might has to be replaced by a dummy app). I have no idea where exactly the Google app itself would be needed, so maybe a dummy app can also do the job.

It’s strange… I’ve done that, but i’ve got usb connexion problem. I’ll retry in a few moment…

No installation (twrp flash) problem for me :wink:

Space is mentioned as an issue in this thread. Android Auto on a virtual machine

Bad issue… :frowning:

It seems that finally a full workable solution (confirmed by a few users) is available here:

Just flash the zip file and reboot.
I didn’t tried myself so it would be good to get some more feedback… :wink:

Just tried it on my OnePlus 8T and got the “No Free Space” message so I couldn’t install it. Is there any way I can expand the system partition (preferably without building my own image)?

1 Like

Hello.

The app will be discontinued soon, gg prefer its ‘gg assistant’ for Android 12…