Building GSI Image (/e/ Android 10) - Here is the tutorial

Prepare the computer for GSI / Treble Images

According to Guntram’s recommendations installed the computer.

The scripts are from Guntram, I honestly don’t know much about it, I just start and run. If any questions arise, it’s best to search the internet for answers.

As operating system LinuxMint 19.3 (I installed the xfce version) was recommended (not newer yet, because of the packages that are installed there). Also I use the system EXCLUSIVELY for building images, nothing else, otherwise I have my Linux on the laptop…

I specially installed a new hard drive (500GB SSD) in the home PC, installed Linux Mint 19.3 there. Manual partitioning, 30GB for “/”, rest for “/home”.

I also had the bootloader installed on the SSD, NOT where Windows is installed. I wanted to start it via BIOS boot menu, but lo and behold, although I have the bootloader (GRUB) installed on the SSD, Linux recognized that Windows is also installed somewhere, and offers it to me in the boot menu. So in the BIOS I set the boot order to the SSD as the first option. If I remove the SSD again, I set the m.2 SSD as 1st option again and Windows (should at least) boots as if nothing else had ever been.

Why no VM? According to Guntram should be at least 12GB RAM available, because the computer is very busy, in the VM (with it I had tested) I had 8GB RAM, there nothing more responded, therefore then also rather “real” installed.

The PC consists of a Ryzen 5 1600, running stable at 3.8GHz, and 16GB RAM.

Here are some data that were created during the creation of 2 images: After the 2 files were done, 186.4GB (!!!) were created on the hard drive, also the script ran for 167minutes and 5seconds.

You can assume that at least 100GB of data was downloaded, then compiled etc. etc.

After LinuxMint 19.3 is installed, run all updates.

Note in between, I backup the system often with Clonezilla, in the different “stages”, without installed addons, with installed addons etc. etc. Depending on when an error occurs, I just go back to the last backup stage and continue there again, so I don’t always have to reinstall the system completely. But everyone as he wants. Is only a hint…

First we install the SDK package from Google (yes, it has to be, unfortunately)

Unpack the file in the home directory into the folder “platform-tools”.

Now we open the file ~/.profile with a text editor. If necessary activate show hidden files. The file is located in the home profile.

There we copy in:

#add Android SDK platform tools to path

if [ -d “$HOME/platform-tools” ] ; then



Save and close.

Then we update our environment with the following command in the terminal:

source ~/.profile

Alternatively reboot, just for reference…

After that we run:

sudo apt install bc bison build-essential ccache curl flex gcc-multilib git gnupg gperf imagemagick lib32ncurses5-dev lib32readline-dev lib32z1-dev liblz4-tool libncurses5 libncurses5-dev libsdl1. 2-dev libssl-dev libxml2 libxml2-utils lzop pngcrush rsync schedtool squashfs-tools xsltproc zip zlib1g-dev lunzip openjdk-8-jdk python perl git git-lfs libncurses5 xmlstarlet virtualenv xz-utils rr jq g+±multilib libwxgtk3.0-dev

Furthermore repo is needed, we install it as follows via the terminal:

mkdir -p ~/bin

curl > ~/bin/repo

chmod a+x ~/bin/repo

Then you can configure Git, I don’t know if you need a user account, I created one.

git config --global "your_user_name

git config --global

In the home directory we create the folder /home/user/srv/e

In the folder /e we copy the two files in. and

In the folder /e we open a console and then simply enter without root privileges:


Now everything should run automatically and you should find the finished image files in your home directory under /home/user/build-output.

If you want to restart, delete the directory “base” under /home/user/srv/e/frameworks, otherwise errors will occur.

If you want to start from scratch, delete all files and folders under /home/user/srv/e EXCEPT the 2 files and

If a file is not created, you can try to create it with the file.

As you should know, the lines beginning with “#” are NOT considered. If you don’t want to create the “b” version for example, just put a “#” in front of the line, whereas the “a” version you want to create must not have a “#” in front of the line.

Example from the

####### Built Variante eingeben ##############




The files are here for download: in Folder “Scripte”.


Instead of a heart
@anon26953564, I would especially like to thank you because it’s your steady and untiring dedication that has made Q-GSI a firstclass replacement for device-dependent CustomROMs.
Thank you very, very much @anon26953564

1 Like

…but Guntram did the actual work, I just create the images. Should not be forgotten :slight_smile:

1 Like

If you say so, then so be it. But G. aka h*186 builds LeOS and no more /e/OS ROMs - unlike you. And I like /e/OS ROM visually better than all technically interesting LeOS-Q Full variants. I’ve tried several LeOS releases, even LeOS-R (Lineage18.1, AOSP Android 11), but not a once in a lifetime ROM lingers in any of my devices. I like the /e/OS ROMs, even if they are not perfect. And so you have my thanks.

1 Like

Hi SuzieQ, I just want to make sure that all the praise doesn’t just go to me, I just have the images created. Sure, I could stop doing that, but I’m using the system myself again now.
I had the Volla Phone (Gigaset GS290) for a few months, but the quality of the workmanship and also the system (Volla OS, Android 9), could not really convince me.
Therefore, I preferred to use my Redmi Note 9pro myself, with /e/ Android, and order a new Note 9pro for my mother.

But apparently, the people here at /e/ Android do not want to go into the GSI creation at all. I had already messaged @GaelDuval via Telegram, but got no response. @Manoj also doesn’t answer in this thread here: About the GSI category So it seems that there is really no interest on the part of /e/ Android to create GSI files. That is actually a pity.

I also tested LeOS on the 9pro months ago, but it didn’t run, only bootloops. I will test it on the new 9pro, but I have to wait a few days until I can unlock the bootloader.

The next image comes then probably on 05.04. evening online :slight_smile:

This is not for lack of an interest it is just that we do not have resources to work on GSI at the moment. We have added some developers recently and hope we will be able to focus on GSI related development as well.

1 Like

That would be nice if that would work. Thanks for the feedback.

1 Like

Hello e_user_poco

Thanks for “staying at the ball”. I have tried installing your GSI succesfully with my xz2c (20210325), today installing Exposure Notifications didn’t crash also, it didn’t work a couple days ago. My next step would be to install it on a tablet. My question regarding the GSI is updating. How can one accomplish that without losing data? Since you deliver whole images it allways must be installed fresh.


first make a backup as a precaution, then, based on these instructions GSI Installation on Redmi Note 9pro with Super Partition and root , at point 7 simply DO NOT delete the data, so the new image is installed and the data should still be there.
This is how I always do it.

Tomorrow I will upload the new images with security updates from April, I can’t do it today :slight_smile:

Greets :slight_smile:

Just update the phone, convinced me to try it out on the tablet. Thanks!

Where would we get the following files - looks like links are dead and

I am looking for the two files too. Does anyone can provide them? and