CUSTOM BUILD - Android 10 (Q) eOS GSI

@harvey186 I’ve installed your eQ gsi ROM and can’t access the SD card but it seems the LeOS Q gsi ROM I do have access to SD card. Any ideas why the eQ version says the SD card needs reformatting but LeOS doesn’t?

Mhm, the eOS Q GSI has newer sources. Could be that lineage has changed something in that way.
On my yesterdays Android 11 GSI build I’m getting the same message. On my Android 11 you can ignore this message, don’t know if it also work on Android 10 GSI.

Same issue here. I did click the format sd card but it still doesn’t show up. Tried restarting but it asked to format again.

Also I just found out that Bluetooth audio isn’t working on my Nokia device.


It is an unwanted proposition,
It is not needed,
You will lose your data.

If you already have did it,
reboot to TWRP, select the sd-card in the advanced wipe menu, change the system format of the sd-card partition to another format (ext3)
Go back to the TWRP reboot menu and choose recovery
Go to the avanced wipe menu and change again the sd-card partition to the right format (ext4)
Go to the TWRP reboot menu and choose recovery.

Now it’s fixed
you can reboot to system if installed,

If not, be sure to not disable the MTP protocol (in the TWRP mount menu)
Your PC file manger must now recognize the sd-card, and you must be able to copy the to the sd-card
after wiping and formating the needed partition (described in the how to) you can install the /e/OS

1 Like

Yesterday I have found out too on my Xiaomi MiMax3. BT phone voice is working, but audio not. No idea what the issue cause is :sob:

The Samsung Galaxy S7 SM-G930F ‘herolte’ does not officially meet the requirements for ‘Treble Project’. But after several attempts I was able to make the SM-G930F Treble GSI compatible. For the first test @harvey186’s eOS GSI Build eOS-17.1-20200927-UNOFFICIAL-treble_arm64_avS ‘A-only’ was used.

The first startup process ends with displaying a tiny section of the bottom arc of the animated /e/ logo and it looked like the system was frozen. The hopping point was also visible.But the system rebooted by itself and the second startup went through in the usual way. The SIM card & mobile phone number is recognized, the Wifi works via Wi-Fi 802.11ac.



I just noticed again that the /e/GSI phone reboots by itself after about 10 minutes. After that it repeatedly reports an error with the mciroSD card, which was formatted correctly in the device and worked fine before. Well what? Nevertheless I treat myself a good cup of coffee :o))

1 Like

very good. enjoy your coffee and sweets

1 Like

Latest LeoS-Q build is available at;O=D

It’s based on latest sources and includes working Seedvault backup/restore option

I just buy a Oneplus Nord and tried to flash e on it but I can’t run the fastboot oem ignore_anti command (result: remote: ‘unknow command’) nor the fastboot erase system which result in a FAILED (remote: ‘Check device console.’) message.
Did someone try to flash a oneplus nord?

Do you use latest adb/fastboot tools?

Not in first place, but i also try with the latest official site.
Same result. :confused:

Your device has a superpertition.
You need to go via fastboot reboot fastboot

Use this howto as example

I’m gonna try this, thanks !

It’s worked much better! eOS is now running on my OnePlus Nord.
Some things not perfectly working (handling of the front camera hole) but usable for a daily phone.
Just a question about the updates, I suppose I won’t receive OTA updates with this build?

the creator of the last build is using it and he will build from time to time. But GSI can updated via OTA. It must always flashed manually.

This is an vendor issue. you have had Android10 on your device before flashing eOS, right ?

Good news for the build!
Once I’m running eOS can I flash it without erasing /data?

Yep the last OxygenOS 10

That’s NOT the original stock version, right ?

Yes, as long it is android Q no problem.

OnePlus Nord was released this year with Android 10 on it

OK, Sorry, sure, OnePlus has OxygenOS as stock android.