/e/ OS on Sony XA2 recommendable?

Hi there!

ATM I´m using a Z5 compact with a custom LineageOS + microg since ~2 years.
So far I´m very satisfied with it but time has come to upgrade the hardware.

I ordered a XA2 as I hope it is not too tall for me compared to other/my compact devices.
As I´m watching this project quite long now the decision for this specific device was also because of the official build of /e/ available to it.

But - is it recommendable as a daily driver?
I do not like the launcher of /e/ and prefer the Sony one but I guess this is something I could do quite easily. What about other quirks I should know of before installing/deciding to /e/ (if the hardware fits)?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

There are recent unofficial builds of /e/ for the Z5 Compact if you want to try /e/. Just search in the forum for ‘unofficial suzuran’ and you should find it. I can post a direct link when I’m back at my computer

You can backup your existing L4Microg setup and flash /e/ to see if you like

1 Like

Hi @CaseSensitive, I use XA2 pioneer H3113 as daily driver. It’s a good device and eOS runs on it very well. I ran the pie test build on it from August last year up until Xmas and I’m running it again at the moment until the Q version is released which should be very soon.

You ask about quirks. Well. I’m not a power user of apps so there may be things that I’m not aware of. Adaptive brightness has always been a bit hit and miss so I usually turn it off. Video calling in Telegram became possible on this device/OS not that long ago but the sound and picture quality is not as good as on the iPhones that the rest of my family uses! But I’m not complaining.

XA2 is an A/B device which is something to be aware of if you ever run into problems later. You will see steps in the install instructions to deal with this.

EDit: Forgot to mention, pie testbuild has not been updated since August so obv security patches out of date.

1 Like

Hi @CaseSensitive,

Well, some of us are doing it. Perhaps it depends on the use as well, in my case, it is very simple:

Please see the following as well: Installing /e/ pie on Sony Xperia XA2 - #4 by sonyxa2

I hope /e/OS will suit your needs

1 Like

Here’s a post about the latest build for Z5 Compact

I did that some time ago. That’s how I know, I don’t like the launcher/appearance of /e/. But I want to support the project - so, new device - new try!

I just got the device today and so far it looks quite good to me except the camera quality seems very sadly not to reach my Z5C - so right now I am really unsure if I want to keep it.

I really don’t know what this means?!

Basically I’m not unfamiliar with rooting and flashing but could you please tell me if I can try /e/ and revert completely if I should decide to send it back?

:slight_smile: Pretty much the first thing I did the first time i tries /e/ was to installer. As I wrote in another thread

1 Like

You can reflash the original stock ROM. But - as far as I can tell - once you have unlocked the bootloader, can’t re-lock it, which means you have voided the warranty and you won’t be abe to return it - see Sony’s official "unlocking’ page

There are some posts in XDA Forums - e.g. here and here - claiming that it is possible using a tool called ‘Newflasher’. This may or may not work, but I woudn’t bank on it.

Unlocking bootloader is done via Sony website so it is on the record so to speak. Can this information be searched and discovered by a third party? I Don’t know.

Unlocking bootloader also removes DRM keys (something to do with camera) irretrievably unless you take specific steps to back them up somehow. I believe they are located in the TA partition, aka Trim Area, I think. All a bit too technical for me, but you can do your research and this post on XDA has some insights.

Thanks to all your reply. I tried Sailfish X for a few days and now I’m on e since yesterday. Pretty impressed how far this project has come!

But I do have a big issue:
Phone app crashes instantly and repeatedly when making a call. The call is still active but I can not interact with it. How do I fix this? Restart didn’t help. Flashed latest version with no problems happening.

Hi @CaseSensitive is your issue similar to this issue reported on Gitlab . If yes pl can you add to the comments with your observations if any. We have a developer assigned to work on it and hope to resolve it ASAP.

Yes, same issue.
Someone has already commented with issue on same device and also same workaround.

Don’t have a gitlab account, too.

To optain root I have to flash Magisk?!
Would like to use Afwall. Somehow I’m wondering why root and a firewall is not available ootb.

Because for many (most?) of /e/'s potential users, a rooted phone is not necessary or desirable. /e/ is not targeted at geeks, but at the majority of users who want /need a phone that will ‘just work’ with the apps they use every day.

People who want a rooted phone will probably have enough knowledge and experience to root the phone themselves, and /e/ doesn’t put any obstacles in their way

1 Like

I just installed /e/ pie test build on my Sony Xperia XA2 and all runs well. I don’t like the launcher like u commented and will now try others. I upgraded the cloud drive in /e/ on the web but to use it on the phone u need the NextCloud app. It took me forever to find the QR code. On the website on a computer (settings>security) you can find QR code when u set up an app password and then u get option to see a QR code that your phone can scan. I took a screenshot:

Here’s the file (right click and save image as):


I also got my contacts setup online from a computer and then add an /e/ account to your phone if u haven’t already and it syncs contacts that way.

I’ve found all the hardware works. Front and back cameras and video. Bluetooth audio and I’ve sent files from one phone to another with BT. Didn’t check NFC yet but the finger print area works. 5G WiFi is stable. Phone and speakerphone works just fine. Battery is just awesome!

Oh, and I did root it to run AFWall and I flashed Magisk zip from recovery. AdAway in F-Droid is very good too.

1 more thing I did-the keyboard is missing gesture glide typing. I installed the Microsoft SwiftKey app from the Aurora store after installing that firewall and then don’t give that keyboard permission to get on the internet.

Hope this helps!


Hey Marty, Well done getting eOS onto your phone! Did you not realise eOS Q upgrade was released on Monday?

It would need a clean install with Format Data etc but you’re good to go from pie testbuild.

1 Like

I did see Q was out for testing now and based on your positive review, I’ll try it before I get too moved in.


1 Like

Did you have to flash twrp again? I just wanted to flash magisk but noticed there is /e/ recovery installed instead of twrp and I’m quite unsure how to securely replace with twrp.

I did use Afwall and adaway on every phone for now. But I found an app called “Tracker control” and it seems to do what I need so far.

I’m missing the swipe keyboard, too. I had the Sony keyboard installed on previous devices. Will have to look if this is easy or complicated and what you mentioned does the job maybe too.

I installed /e/ pie twice on the Sony Xperia XA2 because I decided after it was installed that I wanted it rooted after it booted and I set it up. I rebooted into the new recovery and couldn’t get ADB to work on a sideload with the /e/ recovery. I rebooted into TWRP. I checked with an app called Root Checker (Aurora Store) and it did not take but ADB works there and TWRP also does backups so here it is:


MD5: e7ebbc88d9c96b04499571ae9bf68f38

I installed the entire /e/ OS again and then let it boot to Lineage recovery after putting Magisk zip file on the micro SD card and installed from that. Then rebooted again into the recovery and then reboot into the system. Once in the system, the Magisk app wanted to update and it said it was fixing the rooting process. I then checked with Root Checker and I was good to go! :+1:


So you’re telling me that to root it’s necessary to install Magisk prior to /e/?

What is this file for? Is it a modified TWRP?