/e/OS 'Q' on Samsung Galaxy S7 'herolte' | A unofficial 'Q' [kuː] Build based on Android 10

Even before /e/ removed the former premium ePhone Samsung Galaxy S7 (herolte) / S7 Edge (hero2lte) from the eSolution store ttps://esolutions.store removed, /e/ forum member LauenzG has persistently and monthly provided us with his unofficial /e/OS 'P’ie based on Android 9. This is great and I can’t say thank you enough to the work effort: Much thanks @LaurentG

« Le roi est mort, vive le roi » [lə.ʁwa.ɛ.ˈmɔʁ.viv.lə.ˈʁwa] (French for “The king is dead, long live the king”) is the herald formula used in France to announce the death of the old king and simultaneously proclaim the new one.

The herald (late Middle High German heralt, heralde from Old French héraut, haraut, hiraut, possibly going back to an unattested Germanic word) was an official messenger of a feudal lord in the Middle Ages, a predecessor of the diplomat. Source: wikipedia

Now even an unofficial /e/OS “Q” based on Android 10 is available. In the second attempt within a few hours, our universally esteemed /e/ forum member @itsclarence has shown that a customROM building is possible not only under LineageOS 17.1 but also with /e/ OS “Q” [kuː].

Edwin, not only for this, if I could, I would send you the already offered thank you package spoon caviar and a bottle of champagne - also non-alcoholic organic champagne.

To be continued …

2 Likes

First impressions of /e/ OS ‘Q’ e-0.15-q-20210305-UNOFFICIAL-herolte by @itsclarence

Yeah, /e/OS Q on Samsung S7 herolte SM-G930F is wonderfully. I just enjoy seeing the /e/ animation with the bouncing-● and the BlissLauncher homescreen. A familiar image - for me a sympathetic image to look at again and again.

suzie-q_ccr


integrating a microSD card

When integrating a microSD card, I unfortunately found that this memory could only be used as mobile storage, but not as an internal memory expansion, although the format menu offered both options.

eosq_internal-sdcard-mobil

The error occurred equally with a 64 GB and 32 GB microSD card. I seem to remember that this feature was not supported by stock Android 8.0.0 either.


Users of this ROM from @itsclarence are emphatically asked to share their experience so that the ROM builder can possibly fix one or the other bug.

3 Likes

I have installed this unofficial Q build, as well, on a S7 Edge. So far, very few issues. One major one concerning the phone dialer, however, but it is a preexisting issue with the stock Android dialer (it appears to be the same dialer that comes with Oreo). A replacement with Simple Dialer from F-Droid fixed the issue (thanks to @mcmd for the suggestion). I also have an issue with sound dropping with the speakerphone on, but this is across various builds. I’ve posted in Troubleshooting, to see if there is a solution. YMMV. Other than these, so far I am very happy to have Android 10 on my phone. It is much better than Oreo. Lord knows I would never see it from my provider.

2 Likes

@itsclarence informs us: “This one is based on the latest LineageOS sources and TheMuppets-vendor.”

itsclarence ...

Hi Edwin, I often use the dev-signed unofficial LOS 17.1-microG ROM from @ Exodusnick.

The source code is based on @ Ivan_Meler, but is partially revised and works better, especially in the modem (echo) area.

1 Like

e-0.15-q-20210306-UNOFFICIAL-herolte

Hui …, this eROM boots enormously fast; it feels much quicker than the previous version …

2 Likes

I’m afraid the latest build fails on mine. On reboot, the screen turns red after the Galaxy splash screen, and gets stuck in a connect/disconnect loop with my PC. Also got an error 7, so made the necessary edit.

EDIT: my bad, I downloaded the build for the plain S7, not S7 Edge. Will try again.

I successfully installed the latest build, with no error 7.

1 Like

I had trouble with the phone dialer again, so replaced it with Simple Dialer from F-Droid. I’ll concur with the above assessment. It seems to be quicker. I haven’t found any other issues, for now.

Could anybody short explain how to upgrade from unofficial Pie to Q please? That would be nice.

Thanks in advance.

In my opinion there’s only one way and that’s to do it with a super clean flash to avoid bugs.
So format data and wipe cache/dalvik/system and data.

2 Likes

Great, thank you very much.
Will try the next days and give feedback.

A ‘clean flash’ - as @itsclarence already mentioned - is the safest option. However, since this deletes all data anyway, it might be worth trying to make a ‘dirty flash’, because there are many surprises waiting for the user who is prepared to take risks - see for example here: Dirty flash /e/ over LineageOS for microG - all apps and data still present.

The ‘dirty flash’ does not damage your device. At worst, the attempt ends with a bootloop. Then boot into the TWRP recovery, format and delete and install ‘clean’.

2 Likes

I also had problems with the default dialer. Replaced with simple dialer from F-Droid. Works. But when I have a call, the other person hears an echo. This is bad. Anyone an idea how to solve this?

Hi @peschie1967 This is a known issue that plagues some Samsung Galaxy devices. My S6 has it bad and my S9 doesn’t have it at all. Searching the forum will result in many such cases, with no apparent resolution.

In the case of my S6, I work around this by not using it to make calls via the Dialer(!) but rather I use Telegram to make calls (to other TG users of course), as this method does not present the same echo issue. Perhaps that is an option for you.

Let us know if you come up with something that resolves this issue so that we may all learn.

Best of luck.

@mcmd thanks for your answer. I remember when i used LOS 17 that there was a similar problem. I will test and if I find a solution I will report. Since I use the phone daily, the option with Telegram, is not really a good solution.

Hello,I installed it on my Galaxy S7, also included sdcard and encrypted it.
USB-Android access via adb doesn’t really work constantly. The authorisation window reappears around every 20-30s even if you allowed access for your computer constantly. As I need this I have to go back to “p” for now.
Haven’t tried that unencrypted yet.

regards

Reiner

Edit: There is a chance that it was caused by a flacky cable. I have to check on that.
Edit 2: Unfortunately it was not caused by cable or plug. So going back for now on “P”

Hey,
I’ve downgraded my S7 (G-930F, Exynos version) from Lineage 18.1 (Android 11) with microG, which was unstable but globally OK, to this /e/ version based on Android 10.
I first tried dirty flashing, but I had no success (launches, but crashes).
I made a clean flash, and… what a smooth experience ! The phone starts so fast, everything is very stable (less the dialer already reported, I installed Simple Dialer instead), and it even fixes some previous bugs in /e/ officially Oreo based version.
So, just a huge thank you for your job. If you need testers, just ask, i’ll be happy to help

1 Like

The Simple Dialer has a minor issue. It hangs upon the ending of a call, you have to close it manually. Also, audio while accessing voice and keypad automated systems, the audio is truncated, but understandable. Once you have gained access, there is no audio issue.

One big issue, when I get a call, the call gets terminated when I pick the phone out of my pocket. I try to be careful with how I grab it, but it makes no difference. I have an idea, that if you touch the screen anywhere but the accept button, the call will get dropped.

When accessing settings, the first option is to “Customize your Pixel”. That seems to be the only issue with the OS itself. I’m pretty happy with it.

I don’t know why this happens, but I remember there was a thread about it happening on eOS Q on FP3, so seems to be the case on other Q builds as well.

Perhaps has something to do with the base Q build these builds are based on.

Another good thing, I have very slow battery usage, compared to Oreo.