Fairphone - FP3 - FP3 - Documentation Suggestions

Please add your suggestions to improve the documentation for the Fairphone - FP3 - FP3 here …

Addition to avoid confusion:

++++

Installing /e/ from the bootloader

  1. Unzip the archive [in Windows Explorer or any other tool on your laptop you’re normally using]
 unzip <zip>

+++++
Add a screenshot from Fastboot Mode screen.

In section named

Getting a fastboot error ?

There are several fastboot commands that start with a upper F: as in Fastboot flash boot boot.img
For copy/paste to work, they should be fastboot.

1 Like

Link in tip at bottom should not mention […], Please create a dedicated thread on our community forum ; but be same tip as at top of page (with a lower case p for please :wink: ):

Tip: If you find an issue with this installation document or to suggest any improvements , please add your suggestions to this topic on our community forum

I am new here, but it seems that recent version of fastboot allows to avoid some problems.

This makes me suggest to remove the 2 messages indicating:

On previous versions of fastboot , the command is fastboot oem unlock

At least, it seems to me that is should be changed to was.

The workaround for the occuring problem: couldn’t parse partition size ‘0x’ Did only work partly. The thing that finally worked was to use the command:
Fastboot flash boot_a boot.img
Without the previous commands, so in total:

fastboot -w
fastboot flash system system.img
fastboot flash boot_a boot.img
fastboot flash vendor vendor.img
fastboot flash dtbo dtbo.img
fastboot flash product product.img
fastboot flash vbmeta vbmeta.img
fastboot flashing lock

Otherwise the phone would not boot at all.

The version of fastboot that came with debian buster and ubuntu bionic is broken. If you keep getting mke2fs errors, this is a known problem in that version but they included it in their release anyway, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=924591

I worked around this by doing the install from xenial, which worked perfectly.

1 Like

The solution is to use the current Android SDK platform tools directly from Google anyway.
Section “Requirements” step 2 of the install guide includes a link to a setup guide to achieve this … https://wiki.lineageos.org/adb_fastboot_guide.html.
An additional hint was added to advise users to really follow this setup guide to avoid “unexpected issues”.

Another option, but is that easy enough? Installing from the package manager tends to be the easiest approach…

But I don’t understand why the distributors still provide a packaged fastboot if for whatever reason they can’t make it work (from what I gather in the link above, it seems fixing fastboot would break other parts of their system so they chose not to).

(sorry for the duplicate, I’m still learning how this works…)

1 Like

Hey, I am new to e/OS and the last custom ROM that I flashed is atleast 5 years ago, so I am quite deppendend on the guide.
For unlocking the bootloader, after you already are in the bootloader, I have to finally unlock it with the command

fastboot flashing unlock

this worked for me, but the step afterwards

  • The device reboot automatically. It will show a warning. Press Volume + or Volume - to display boot options, select fastboot and confirm with Power to reboot on fastboot

Wasn’t the same for me. I only could interupt the reboot with Volume + or Volume - nothing else.

Did something changed recently?
Now when I boot into the bootloader again it says that fastboot is enabled and the device is unlocked.
I can select:

Recovery Mode
Start
Restart bootloader
Power off

Nothing with fastboot. I highly suspect that Recovery Mode is the way to go for the next step.
While fastboot -w in the bootloader gave me a waiting for device or something similar.

Edit: now I tried again fastboot -w on the bootloader to see the exact message and it erased my user data this time, without changing anything. :thinking: is this the right way or did I fucked up?

In Failed update, why (q0.17, FP3) the original poster said something about TWRP being mentioned in the install instructions.

After having a look I indeed found

TWRP

  • Errors while running TWRP version 3.4.x.x or above - Try downloading and using a previous TWRP version… below 3.4.x.x
  • In TWRP if this error shows up failed to mount /preload - Try in TWRP wipe screen in advanced menu select preload and swipe to wipe
  • /cache/recovery/xxx -> no such file or directory error while flashing a ROM - On PC run adb shell in the console now create a folder called recovery for e.g. here the devicecode name is violet “violet :/cache# mkdir recovery”

in an expandable section called “To find some troubleshooting tips… click here”.

I assume that’s part of a template included in all/most docs?
Not sure if it applies to the FP3.

1 Like

Thanks for pointing this out @Ingo_FP_Angel …let me figure out a way to selectively disable this in the template for some devices

1 Like