Feedback for v1.15

  • Vendor: Xiomi
  • Device: Mi 11 Lite 5G NE
  • Device: Lisa
  • Version of /e/OS /e/OS which existed previously: 1.11-s
  • Is the device Rooted / Not rooted

Lisa finally got S-1.15 - and my feedback after two weeks: All good! Thanks for your great work, guys!

  • Vendor Name: Samsung
  • Device name: Galaxy Note 10+ (SM-N975F)
  • Device CodeName: d2s
  • Version of /e/OS or Stock which existed previously: lineage-20.0-20231010-nightly-d2s-signed
  • Version of /e/OS: e-1.15-s-20230916331435-dev-d2s
  • Is the device Rooted / Not rooted: Not Rooted

Video output via USB-C dock now works without having the device reboot! Here are some observations:

  • Major visual artifacting while desktop mode is enabled, both on the device itself and the external display. Looks as if some element of the UI were shuffling between displays.
  • Regardless of enabling Force Desktop Mode (developer options) when there’s a keyboard connected, it’ll be impossible to input text on any field. On-screen keyboard shows up for a few frames and disappears, but input is not inserted on any text field.
  • Switching apps while docked might send the app to the phone screen instead of the external display
  • Enabling taskbar (System » buttons) shows up on the phone, not the external display.

Overall it’s a great step forward and it’s almost there for light usage, I’m really happy how things are progressing for /e/!

Sony
XZ1 Compact
lilac
1.13
Not rooted

Same issue/failure as when I tried to upgrade from 1.13 to 1.14 (This time I attempted to upgrade from 1.13 to 1.15, skipping 1.14, which had failed for me before.)

I downloaded the update and initiated the install process.

Phone rebooted and started install (I think), but is stuck on a slightly illuminated, dark, blank screen and does not advance.

A press of the power button, which would normally deactivate the screen, does nothing.

I had to recover in the same way.

Aside from that, there is still the lack of audio during calls, which I reported 5 months ago. I believe 1.8 was the last version where audio worked normally on this device. There doesn’t seem to be anyone investigating that issue.

Seriously, I think I have to downgrade to 1.8 to have working audio during calls again. @Manoj or anyone, where can I get a 1.8 build?

https://ota.ecloud.global/api/v1/lilac/dev (see the “url:” lines).

lilac isn’t mentioned at https://doc.e.foundation/devices, by the way, and it’s not on the 1 lists 2 to get /e/OS T. Seems dropped?

Thanks for the url links.

Yeah, I started on /e/ with @petefoth 's builds; later Murena picked up the device and started issuing OTA updates, which worked fine up through version 1.8.

My XZ1c is definitely messed up, so maybe I should just format and start over at 1.8. I actually can’t seem to boot into TWRP as of this attempt to upgrade today, either.

Yes, it was dropped a long time ago when I stopped being the community maintainer for the device. Since then I believe /e/ have made offcial builds but only made them available OTA, for users who started using /e/OS on lilac when it was officially supported. So you can still get official Q bulds from /e/, but

  1. They are built using very out-of-date device and kernel code. The unofficial Lineage OS ROM(s) on which the /e/OS build was based have long ago moved on to more recent Android versions: the latest is Lineage OS 20.0 / Android 13 / T , three versions on from /e/'s Android 10 / Q.
  2. /e/ wont ever be moving this device to T. If you want T, and a privacy-respecting ROM for this device then I suggest you move to either LineageOS for microG or IodeOS. The builds for both are unofficial, so you wont get OTA updates, but you will have an up-to-date ROM

See my comments above. Sadly, /e/OS on lilac is a dead-end (IMHO)

2 Likes

I can now confirm that v0.2.28.233013 doesn’t behave any better!

Vendor: Murena
Device: Fairphone 4
CodeName: FP4
OS before update: /e/OS 1.14-s-20230816320616-stable-FP4
Rooted: False
Update went fine, some issue though…

1# Screenbrightness issue still there, it dims without any reason. When the sun is out, it is almost impossible to read the screen.
I have turned off any setting related to this, but no improvement.

2# Ghost inputs issue still there as mentioned in the FP4 topic. It is less, but still there…

3# Microphone issue, a lot of people complain about they can hear me badly when talking. This is with phone on my ear and when using the speaker option. When I’m a little further away they can hardly hear me talking. This issue is already present since I started using the FP4 in Dec last year.

#4 Not able to select manually another Network provider, message: “Couldn’t find networks. Try again.”
For now the workaround with 4G works…

#5 The camera is not able to focus well as reported by outsidethebox and here Camera has focus problems after update to eOS v1.15 - #3 by mungo

Vendor Name: Fairphone
Device Nem: Fairphone 3
Device Code Name: FP3
Previously version: 1.14
The microphone shutdowns without reason, when I send an audio via whatsapp there is no sound. To re activate the microphone i need to make a call and activate the mic.

v1.16 is on the way, currently planned to come October 24 - November 7.

I kinda stopped coming here because I have fewer and fewer issues. It does not seem quite fair for the devs! :sweat_smile:
I did […] → 1.11-s → 1.13-s → 1.15-s and those versions were OK on my /e/-bought FP3+ (which will soon be three years old I think). Thanks for your work.
I just have Camera has focus problems after update to eOS v1.15 now but nothing too annoying.

1 Like

Issues #1 and #3 seem to be related to Android in general as they are listed on the fairphone 4 issue tracker..
I am also experiencing issue #3 and it has gone worse since the latest update to 1.15 :frowning: I need to use earphones now to be sure I get heard.

Vendor name: Fairphone
Device name: Fairphone 3 (original camera module)
Version of /e/OS previously: 1.14-s stable
Version of /e/OS now: 1.15-s stable
No custom recovery
Nova launcher

I believe it is since 1.15 (maybe since 1.14, but not earlier) that in Telegram when I watch a video in panorama mode (phone on the side) and full screen that the three virtual buttons (back, home, minimized apps) keep sliding in and out on the right side at high frequency. When I adjust the volume and the volume bar shows on the right side, it also moves back and forth with the three buttons at the same high frequency. Extremely annoying. Any Telegram users have the same issue?

Hey, I updated to v1.15 on my Murena Teracube 2e (zircona), presumably on the “stable” channel, but now it’s listed as “dev” What gives?

I am having horrible problems with my text messaging on stock QKSMS (from F-droid). I am not using the built-in message app. Sporadically, it will just fail to send, and nothing will work, in or out, until I reboot the phone.

Vendor: Murena
Device Name: Teracube 2e
Codename: Zirconia
previous \e\OS: IMG-e-1.14.2-s-20230825321008-stable-zirconia.zip
current v1.15 \e\OS: [IMG-e-1.15-s-20230913330639-stable-zirconia.zip] (there is no longer a link!)
Device is not currently rooted

Please refer to this guide to find out what you are running currently … [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc

1 Like

Well, yes – there was no link, so I copied it from my phone. What I reported is the version that shows on my phone under “/e/OS version”
Part of what I’m asking about is that I installed it as “stable”, but a very similar version now appears in “dev” that appears to have been released four days later. So where does that leave the (now absent) stable version on my phone? @Manoj ? Should I roll it back to stable v1.14? Or try dev v1.16? I usually avoid dev versions because I use it as my “daily driver” phone.

Galaxy S9

Vendor Name: Samsung
Device name: Galaxy S9
Device CodeName: starlte
Version of /e/OS or Stock which existed previously: /e/OS 1.14
Is the device is: Not rooted

Problems:

  1. The launcher has slowed down: when swiping away an app / returning to the home screen, it always takes a second before app icons appear. I use no wallpaper, just a blank unicolour background.
  2. The sharing menu is very slow: No matter if I’m trying to share a photo from the Gallery app or a text from the Notes app, it takes up to 15 seconds before the sharing menu has loaded suggested contacts and app icons. Strange thing is, when I switch off the screen once the sharing menu is loaded, and then switch it back on, the menu needs to reload contacts and app icons and that takes just as long again.

Pinging @Manoj instead. Why is build 1.15-s-20230913330639-stable-zirconia not offered anymore? Was it retracted?

There is no easy rollback in recent Android once there are different security patch levels involved across the respective OS versions.
This would amount to a new install, wiping your data by default (at least it would be safer to assume so).

Switching from stable to dev would amount to a new install, too, wiping your data by default (at least it would be safer to assume so).
dev is a different release channel/ build type … https://doc.e.foundation/build-status … it isn’t offered instead of a certain stable version, but in parallel for itself.

For what it’s worth …

The stable build for zirconia should come with the next iteration - v1.16 . Will check and update if there is any change in the plan.

  • Vendor Name: Fairphone
  • Device name: Fairphone 4
  • Device CodeName: FP4
  • Version of /e/OS or Stock which existed previously: /e/OS v1.14
  • Is the device Rooted / Not rooted: not rooted

Bliss Launcher issues

Seeing a couple of weird Bliss Launcher display glitches. This isn’t necessarily new to v1.15; that’s just when I started to be systematic about investigating and screenshotting.

Dynamic icon shape inconsistencies and glitches

Summary: Bliss Launcher doesn’t respect the user’s choice of dynamic icon shape, except when creating shortcuts. The current shapes gets baked into shortcuts at creation time, even if the user subsequently changes it.

OK, so Bliss Launcher does not respect Settings → Display → Icon Shape for normal app icons. Instead, it always uses “Rounded Rectangle”. I wish it used the setting and allowed you to change the icon shape: squircles are slightly nicer!

When shortcuts are created, though, the shape configured in that setting is respected, but in a weird way. It is hard-baked into the shortcut’s icon for its entire lifetime, then cropped additionally by Bliss’s “rounded rectangle”.

This can make shortcuts display with grey corners, since “Device Default” is “round”, apparently. See the shortcuts created by Shelter in How to make Advanced Privacy work with work profiles using Shelter - #3 by achadwick, and compare them with their equivalents below. I honestly thought that this was how Bliss marked shortcuts, back then, but it turns out it’s just a glitch.

Workaround: If you want consistency between shortcuts and apps, change Settings → Display → Icon Shape to “Rounded Rectangle” before (re)creating the shortcuts

Icon size and layout fluctuations

BlissLauncher’s layout fluctuates over time. Basically, even if the icons stay in the same place and the names don’t change, the layout changes over periods of a few hours or days, and the icons seem to draw unpredictably at different sizes. This misdrawing can (seemingly) compound and make folders display with odd grey bottom and right borders (last screenshot).

It’s kind of bistable in that the layout algorithm seems to pick one of two sizes for the icons, but the main area and the 4 quick access icons at the bottom stabilize at different times. Which is a bit odd; I wonder if the two zones are influencing each other by adopting different sizes? The screenshots above are ordered chronologically, but aren’t necessarily that close in time (this is over 6 days)

  • Main area:
    • state M1: screenshots 1 and 4 (nice fill, this looks good)
    • state M2: screenshots 2 and 3 (not as nice looking, cant’ really put anything in the gap)
  • Quick access strip:
    • state Q1: screenshots 1 and 3 (consistent with M1)
    • state Q2: screenshots 2 and 4 (small icons like M2)

This glitch affects 3-button, 2-button, and gesture navigation all the same way. The extra space from gesture navigation doesn’t allow the algorithm to make better choices (or more accurately, more consistent and more stable ones)