Feedback for v1.2

Pl share feedback on the v1.2 build for your devices and application you use in this thread. Refer category description here
A poll to get a better idea on each build.

  • I have updated to v1.2 on my device and it is working well
  • I updated to v1.2 but I am having issues (Please share the issue details on this thread)
  • I am not able to update to v1.2 (Please share the issue details on this thread)

0 voters

5 Likes

Hi,
after latest OTA update, mail app first open with a message about database update, but after that it don’t work at all.
Any clue ?
Thanks

Whenever something doesn’t work anymore:

  • go into the Settings app,
  • search for the app in question,
  • terminate it,
  • clear the cache and
  • reboot (to start it ordinary).
2 Likes

Which mail account are you seeing this error on…gmail, murena …

I have 2 accounts, one from /e/ and one from a standard imap account (brassens.heberge.info)

Shared your issue with the testing team and this was the response…

Mail upgrade tested with 2 accounts (Murena and free.fr(imap)) from 1.1 to 1.2 with emerald device. So it works fine. Also checked on K9mail backlog and I did not find any similar reports…

Suggest you raise a bug in gitlab and attach some logs. There may be some other conditions which are causing the problem in your device.

I’m having a problem with email too. Phone is a Samsung S9+ in the US. Gmail quit working immediately after the eOS update. “Authentication error” Worked just fine before the update.

bug raised Mail app not working after OTA update 1.2 (#5872) · Issues · e / Backlog · GitLab

Pl can you add your comments to the issue created by @pmakowski

Sorry, but Gitlab keeps rejecting my Gmail address for registration so I can’t comment on the issue there.

You can check the solution proposed here

Finaly I deleted data from mail app.
It is ok now, I just have to recreate my other imap account.

Internal data and its backward compatibility is something developers often ignore. They do the needed changes in their testing environments themselves and in incremental steps over weeks and months before the user gets it, so they really forget this. This gets still another dimension when the app is a damned fork and has been developed by others, so you don’t even know what they changed internally. And then someday, when it’s really incompatible, the user should delete the crap he has and that’s the solution.

Again I ask: why can’t this be a mandatory step during the system update? Clear the cache of all apps. This would help in the very most cases sounding like “Did update yesterday, nothing works anymore”. Make an option for that.

Hi all,

Maybe we could continue @legrec14’s initiative about /e/OS updates (see the link below).

The idea is to receive and centralize the opinions of people who have already made the update, to have advice on whether or not to make this update on such or such phone or rather wait for a patch etc…

It’s up to you :slight_smile:

4 Likes

I past the response from @Tiquette here for example :

I thankfully installed v1.2 (/e/OS 1.2-20220725206061) on my FP3+ yesterday, right after fully charging it.
Today I realized the battery had only 16% left - after 16 hours running:

Very unusual, as it used to run at least three days (with Orbot, Bluetooth, Corona Tracing, eventually Magic Earth and casual use) on a complete charge:

The phone said that Orbot took 75% (!) of the battery usage after the upgrade - which it never did before.
It had difficulties connecting (hung at some bootstapping point between 10 and 30% of establishing connection) prior to the upgrade.
So I disabled Orbot to see if any changes where happening.

The complete charging today left me with 97% after two hours, and it says that will last two days now.
Since I run Orbot in VPN-mode für most apps I started it again.
Wait and see.

1 Like

I ran into this (solution also in thread), but otherwise looking good:

1 Like

FP3+ on 1.1 here (advanced privacy off, no /e/ account).

I’m half-scared by 1.2 seeing battery-related report by mungo here. May wait a bit to see what people say.

I loved 1.1 for a week or so, but then App Lounge became unusable. Infinite loading, so I only get empty tabs (Home, Categories, Search, Updates). Only Settings are usable. Tried deleting app data, using mobile data instead, rebooting, logging out and in again (always in anonymous mode)…
Wait… While writing this, I got for the first time ever a “Timeout fetching applications” message, and choosing “retry” worked. :neutral_face: Weird.
Also note that during this buggy period, the lounge seemed unable to send me notifications about available updates.

I wonder if the App Lounge goes through an /e/ server (which maybe had issues this last couple of days) or directly hits the same APIs as Aurora (I had no issue with Aurora, except for one time where I had to clear its cache in order to be able to get a new session because of weird I/O errors, but that was on /e/ 1.0).

I guess the battery draining comes from Orbot.
Though I shut Orbot off after five hours at 83% and remaining runtime 21 hours, the phone says that it took 18% of battery usage (Corona Tracing 7%, Calls 3%, Gallery 2% and a few 1%ers).
This gives a total runtime of 26 hours, about a third of the usual.
Since then it became more of what I expect:

To me it seems that Orbot runs as usual on the one hand and on the other requires much more energy to work. I just started it again for half an hour and the result is battery draining again:

Is there any suggestion how to check this process?

App lounge stopped working for me aftee updating to v1.2.

No battery problems so far.