GPS not working : hardware or software issue?

Hello community :smiley:

For few days my GPS is not working on any apps.

In Magic Earth i get a message “No GPS position”, even if i enable GPS search using wifi and bluetooth.

My phone fell on the ground this week, there is a very little impact at the bottom of the phone but all was working fine, … maybe GPS component is broken ? I don’t know … any idea about how i could check if it hardware/software issue ?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello, what is your /e/ version and what phone are you using please ?

Hi,

I am using /e/ OS 0.12-2020093076095 on a Samsung A5 (SM-A520F)

Has the issue started with 0.12 ?

Here is a related issue :

Hi,

Yes it started after this update.
I’m not the author of this post but the issue is the same : no gps even if i enable everything.

I am not using much GPS and i even disabled high precision features (bluetooth wifi) and blocked mosyt of the apps with trust.

But now i enabled all again and disabled trust but gps doesn’t work.

I can get some logs if needed.

Do you think that a reinstall might help or maybe uninstalling this update ?

There are issues with v0.12 causing builds to fail or show un expected behavior. The build has been removed from our servers. Expect the team to come out with a fresh, working build this coming week.

1 Like

This is still happening to me on 0.13, Xiaomi Redmi Note 4 X, Android 7.1.2

It’s being very frustrating, any advices?

EDIT: if I go to another street GPSTest says there’s connection with satellites, but any map does not geolocate me. Also, I cannot use an app that requires geolocation

I saw a thread where someone solved partially this problem by editing gps.conf: GPS won't fix on cancro (Xiaomi mi4)

Other threads:







This is a really, really extended problem and in my opinion, great and considerable problem

Hello everyone, i come back with some news and a solution.

@Anonyme : I did a full reset by installing original Samsung official ROM on my Samsung A5 2017. Even on the original ROM GPS isn’t working, i think that my problem is not related to /e/ but is an hardware issue (GPS didn’t worked after my phone fell on the ground in October few days before i started this topic). Today i put back /e/ last version (0.13).

For everyone on this topic i have a temporary (and funny) solution that is working even for driving with GPS : i’m using an external bluetooth device with GPS high precision (my jabra headphone has a GPS chip, but i think that if you have things like smartwatch it might work too). I used it in my car, the headphone needed to be working on the road all the time but i was able to use GPS efficiently on my phone ahaha !

téléchargement (1)

2 Likes

Hi Manoj,

Any update on when the builds with GPS fixes will be released ?

I have issues with e-0.14-n-2021013099019-dev-d855 on LG G3 D855.
(this is not the latest build but I couldn’t get the latest build to work)

Thanks

There are some open issues reg this on the Gitlab
I am not sure it is an /e/ issue as I just checked with a phone running stock MiUI ROM ( Redmi Note 7 Pro Whyred) . On this Google Maps places me about 50 meters away from my location. This issue is when you are indoors while out door the placement is also accurate. Have seen the same behavior on /e/ phones.

I’m still having problems with geolocation, as even if enable GPS, it does nothing. Not indoors neither outdoors.

Simply any fix is not done.

This happens from some months ago and there was a week working, but not more afterwards.

Hello everyone,

The last update of /e/ based on Android 10 (0.16) fixed my GPS on Samsung A5 2017 :smiley:

Maybe you could try this update too ? (but be carefull because this update broke my boot and i had to completely reinstall with ADB :cold_face:)