My experience on Sony Xperia XA2

sony-experia
user-experience

#1

Hi all,

Using an iphone since iphone 4 and more and more privacy aware I have tried SailfishOS (Jolla) a year or two beside my Iphone (8). But Sailfish did not deliver. Sailfish X on Sony devices has a lot of missing features to replace my Iphone. Then I strumbled upon /e/. So I decided to order an Sony XA2 to install /e/ on it. I decided to go full monty and use it as my daily driver.

Must Haves
I had quite a list of things /e/ had to fullfill:
Hardware releated:

  • Philips Hue
  • Tado
  • Sonos
  • Pebble

And quite a lot of account related stuff:

  • Spotify
  • NS (ducth railways)
  • Bitwarden
  • NordVPN
  • Protonmail
  • signal
  • WhatsApp (hate it, but most people use it)

And a lot of MIcrosoft stuff to use at work

  • Teams
  • Onenote
  • Skype
  • LinkedIN
  • Authenticator
  • exchange mail account

Install
I decided tot install the latest build (20190314). Install was really smooth.
But a boot up things went wrong:

  • Simcard not found
  • bluetooth app keeps crashing
    So i decided to install an early version: 20190312

This operated flawless simcard wise. :wink:

The Good
All the hardware related apps installed fine and all the stuff runs well
Battery seems to hold very long (two days at medium use).

The Bad
For all datahungry apps I had the idea to install Shelter or Island. I preferred Shelter as it is foss.
Both apps didn’t run with Blizzlauncher.
So I decided to install this datahungry apps without any profiling app.
Second Bad thing is exchange support of the default email app. Didn’t work. So I installed MS Outlook, flawless. Yesterday I replaced it with another app. But no idea of the safety of it.

The Ugly
Some apps didn’t install from within Yalp. LinkedIn, Netflix so i installed them using aptoide (main android app store on Sailfish).
One banking related app didn’t install without a reason (I think it found out it’s a rooted device?)
Tried some more bluetooth things but except my pebble none can be connected.
Chromecast couldn’t get it working.

My assumption is there are some “radio” issues with this build?

Conclusion
Although not everything is working I am very, very impressed of /e/. This 0,5 version is good enough to be my daily driver. But I’m afraid to update, as I saw this morning there’s a new build.

Next?
I will use it one week and next weekend I’ll post some updates and maybe I am brave enough to update to a newer build.


How to fix Sony Xperia XA2 missing sim card
#2

Hi @Damio thanks for the detailed feedback.
Please could you help with a couple of queries…

Was there a difference in the way you installed the latest build and the older build. what I want to know is did you try a different way of flashing /sideloading or were you using the same method and it worked for one build ( older) but did not work for the older one?

Please can you elaborate what were you trying to do. Were you not able to add accounts through the email app or from within Setting >> User & accounts >> Add accounts

You are right here as this has been my experience as well. Banking apps usually do not work on rooted apps. This may be a long term bug for us to fix - to make banking apps work seamlessly on /e/

This is an issue with microg since a couple of updates. Earlier it used to work perfectly. we even have a discussion on this here Multiroom audio


#3

@Manoj thnx for you reply.

Install:
I sideloaded both builds.

exchange:
Tried to install my exchange account in de app. Don’t remember if I tried it also by adding account.

For now i’m using bluemail. works very well

Another Ugly thing:
default browser is slow en hangs sometime. Experienced some complete hangs of my phone, killed the browser and everythings runs smooth again. Looks like some scripts hanging default browser.

Now using firefox (my preferred browser since years) and it runs perfect.

Another Good thing:
MAPS!! navigation is perfect… love it.


#4

Hmm i hoped that bankings apps would work on eelo. Can u tell me which bank u use? Im a Dutchie aswell.


#5

@Eelo It’s the app of NN (mortage) that’s not working but my Triodos and Bunq app are working fine. It looks like tap and pay works on Bunq. (not tested yet but activated). So I you coiuld give it a try :muscle:


#6

Ah ok thx. I myself use snsbank. I checked their website and they only warn you about not using their app on a rooted device, but nothing about their app not functioning on a rooted device. So fingers crossed!


#7

Next to ur findings on eelo, i was also wondering what version u were using of sailfish, since u have a xa2. And why u didnt liked sailfish. For me it was also a possibility next to eelo to use for daily basis.


#8

@Eelo I own a Jolla C and a Jolla Tablet :wink:. I’m running Sailfish 3.01 (latest version) on it. It works smooth and runs fine. But it’s all about apps. The Alien Dalvik is based on Android 4 (!). So quite al lot apps aren’t supported. Another thing I discovered is that quite a lot of app rely on G-services. And of course Sailfish don’t support this. In the community there are sailfis packages availible that do deliver G- services to Alien Dalvik. But hey wait what’s the point of using sailfish?

I hoped Sailfish X with a newer Alien Dalvik could do the job. I never used it but in the forum you will discover a lot of things are missing/not working.

Another thing is about updates… slow… slow… slow… The pace of delivering updates is quite slow. and with many things not working on Sailfish X it will take a long time things will be fixed.

I ordered an XA2 to install /e/ on but if it won’t be satisfying I am able to install sailfish on it…

I still love the UI of sailfish, it’s the best there is, and I still hope they will survive. But in the forum I see many diehards fleeing.


#9

I have waited a long time for sailfish to become available on the xa2, now its available but its still only a demo. So that slow proces in combination with alot of things not working and the very small amount of devices its available onade me change my mind and go for eelo.


#10

Same here
:sunglasses:


#11

Update:

The Bad
I experienced some wifi problems so i rebooted. After reboot network problems were over but i had an errorloop saying the bluetooth app has crashed and needed restart. (see Eduroam not working)

The Good
I was brave or stupid enough to update :face_with_raised_eyebrow: The good -> OTA worked on my device.

The Worst
As described in the opening post the latest build still has the “No sim” error. So my phone is useless right now. :disappointed_relieved:

Anyone? How can I install the older working build without losing all apps and data? Can I use ADB push to push the old image to the phone and use update? To what folder do i have to push the image?


#12

Up and running again. Installed built of 20190312 again.

Become handy doing it. :wink:


#13

Some problems that you describe are the same as with Sailfish. I have it on XperiaX, but the simcard-and memorycard reader does not work since the latest updates. I do not know if the updates cause this or if this is due to the quality of the device. After a few years struggling with Jolla 1 I bought an i pad mini for the niceties and utilities like a Triodos app. And since the simcard problem I had to buy an Iphone 6s. How boring that is! The interface and the design of Sailfish are much easier and nicer than Apple’s ! Jolla says that the new Dalvik will make use of micro-g, just like /e/. Well, I am stuck anyhow, for I am not able to flash myself.


#14

Where did you find an installable app from the Triodos bank? I only have it on my ipad mini and not on XperiaX. Cannot find it in Aptoide, nor in apkpure. Is it safe to install the app from these alternative stores?


#15

@Kea Yalp store you can install Yalp store from fdroid. See thread Install F-Droid & Yalp correctly

As far as know this store is save for its “a kind of gateway” to the g… play store.


#16

Hmmm I thought it was related to the build version of /e/.
My present version (20190312 ) works fine. But the newer builds do have “sim card problems”.

But this version has a bug in Bliss launcher. see BlissLauncher on Bacon update (e-0.5-n-201903134246-dev) don't work!

So i’m using my apps in alphebetical order :wink: (as result clearing the cache at startup) and use no folders or any ordering for i know it’s temporal.

Thinking of buying another /e/ supported device (pocofone or mi8/9 (hope mi9 will be supported soon), and using the XA2 with sailfish but your post isn’t hopefull for doing so.


#17

Maybe Sailfish 3 works better on XA2 than on XperiaX. I didn’t buy the XA2 because I want to wait until Sailfish 3 has been improved and also because pictures made with these Sony devices show unnatural red colours. Camera is sharp, but colours, no, not my taste. Sound on the other hand is good, beter than on iphone.


#18

This weekend I spend a lot of time installing ROMs on my XA2.

  • Tried to make a backup using TRWP :negative_squared_cross_mark:
  • Over the air update /e/ :negative_squared_cross_mark:
  • sideloaded latest lineageOS + microG :negative_squared_cross_mark:
  • sideloaded latest lineageOS :negative_squared_cross_mark:

In all install occasions it’'s the same SIM card problem

Installed the latest working /e/ as mentioned above (201903124169). Works fine.:white_check_mark:

So it’s a LineageOS problem, it appears to exist from mid januari. https://gitlab.com/LineageOS/issues/android/issues/117
They said it’s fixed. Maybe the maintainer of this /e/ build can check in /e/? https://review.lineageos.org/c/LineageOS/android_device_sony_nile-common/+/240044/1/proprietary-files.txt

And maybe it’s possible to make build 201903124169 avaible again, for new users. otherwise they wil install a non working version.

It’s the “firmware” directory that’s missing. Some LineageOS users did manage to copy the firmware directory from Android A to B using adb. (failed in my case). Others did install a new firmware file. (didn’t try for I couldn’t find the correct firmware and didn’t want to brick my device)

So i’m a little struck updating, anyone new idea’s?

Using /e/ is still a pleasure. At this moment I see some major points:

  • Bliss Launcher is not stable, Sometimes it crashes and needs the cache to empty at boot to work again.
  • Bliss Launcher don’t work with Shelter or Island.
  • No support for O365 mail accounts
  • Some apps won’t install (linkedin, netflix) no big deal

#19

Update 11-04-2019 : fixed sim card error see How to fix Sony Xperia XA2 missing sim card