Roll back to the previous /e/ OS v.0.23 from v.1.0?

Interesting - I’m glad it’s working as normal for you!
For context I am experiencing frequent audio stuttering / random pauses in playback on my FP3+ since the update to v.1. It occurs both when streaming music and playing files on the SD card. It occurs regardless of whether the connection is wired, wireless (bluetooth) or even using the internal phone speaker.
Could potentially be a processing issue (?) as it seems to be worse when using the device, but still occurs when sound is being played while the screen is off and no other apps are running in the background.

Interesting indeed.

Since you have a Fairphone 3+, you have slightly different hardware in the audio section of the phone. Other Fairphone 3+ users would have to check whether this might play a role.

Does it make a difference if you set Settings - Battery - Battery saver and performance - Performance profile to the max (“Performance”)?
I have it set to “Balanced”, for reference.

Perhaps worth exploring …

Especially note and

I was using Lawnchair even before using /e/OS and stuck with it, since I don’t like Bliss (the default /e/OS launcher).

Thanks this addressed a different issue I didnt realise had a fix!

Same here on fp3+

So @AnotherElk thanks for redirecting me here. Hmm. As mentioned I am on FP3+, I dont run any SoMe, use signal a bit but mostly telegram and whatsapp (yeah I know, no choice) for calls. Whatsapp causes the most issues. I also havent turned on adv priv as i already run openvpn. And I am not on native bliss launcher.
Anything else I can add?

Edit oh yeah, I have noticed that telegram accessing the camera permanently breaks access until restart both for telegram and camera app.
In this case I suspect the new warning system that an app is using the camera as I notice this springing up

1 Like

There goes another promising culprit.
If they don’t find anything on the OS side of things, this could get really tricky.

As mentioned above, I’m on Lawnchair launcher myself.

I should also mention (looking at the other posts) that while my FP3 has a hatful of issues since installing /e/OS v1, problems with wifi or battery drain are not among them.

In terms of potential culprits, I am using this very popular Google Camera Port, which I thought I’d mention, since clashes with camera apps seem to be mentioned a lot above.

The other thing is that while I’m not using Bliss Launcher, I never found a way to uninstall it, so perhaps it could still be the culprit, despite not being in use…? #notadev

I didn’t uninstall Bliss on my phone either, even if I think it should be possible … you were aware of the ADB way, and it didn’t work?

Regarding issues you mentioned … I just called someone via Signal, seems to work for me, I don’t have WhatsApp and Telegram. Camera works, caller ID works, phone’s not less snappy than before updating.

Thanks for all the info, very informative.

I’ve tried a number of different profiles, maxed out the phone does perform slightly better however it unfortunately does not alleviate any of the issues experienced since updating.

I’m using Ruthless Launcher as default. Have tried clearing cache on Bliss even though it isn’t in use, which doesn’t seem to do anything.

Interesting, I wonder if most FP3 users are running v1 without a hitch and issues are limited to FP3+ users only…?

No, I’m on FP3 (not FP3+).

I do though have the upgraded Fairphone 3 Camera+ Module (48MP) - most commonly found in FP3+s - in case that’s a clue, especially given what @Glandos said about Element’s video calls above, and @castoak re: Telegram camera access…

I’ve no idea why that would crash caller ID though, so that one may be a separate issue with the new OS version.

Incidentally, contrary to what I wrote above, I realise I haven’t actually called or been called by anyone via Signal to crash the phone, just WhatsApp and Telegram FOSS. I just tested a Signal call and it indeed seems ok.

I believe it is a wider issue than just the camera, centered around media handling as the update also causes browsers (plural) to crash when handling video and IM apps when handling calls (which may call some video handling protocols idk?)
Aside from that I want to support the user earlier who reported a degraded connectivity - I have substantially less stable WiFi as well as 3g/4G connectivity after the upgrade. I travel the same routes frequently and never used to lose signal entirely and never before saw H+ for internet, but both of these now happen (repeatable in the same locations). So somehow the update has reduced antenna gain (?) or something like that.
Also, I live right next (as in next door, ground level) to a cell tower and now have very poor call quality compared to pre-update.


Can confirm that I am having major stability issues on my FP3+.
Camera is nearly not usanble.
App Lounge is constantly crashing.

Any news on fixes or a new update which patches those problems?

There should be a build for FP3 and FP2 rolling out today…check out the release notes here


Wow great!
Thank you Manoj!

1 Like

I am really excited to see what the bravest of us are about to tell after jumping into the ice cold water one more time.
Good luck to all of you! :four_leaf_clover: :+1:

1 Like

Upgrade to 1.0-20220622198552 was successful on my FP3, although I had to hard-reboot (pressing power-button ~30s) because the phone didn’t come back again after shutting down for the upgrade (probably due to #5655 which I can confirm fixed now).
The unlocking (fingerprint/power-button) is much more responsive now (#5571) and the camera seems to work again as well.
Now I’m very much looking forward to fixes for #5551 and #5369 :slight_smile:

[edit] For me, the Access Point functionality (wifi sharing) stopped working with this release - not sure if that’s an isolated or generic issue? USB tethering still works.

1 Like

Update to 1.0-20220622198552 was successful on my FP3 too, with no hard-reboot required in my case.

The camera seems to be functional again, and the phone faster, for which I am most grateful. I hadn’t been experiencing others’ problems with unlocking/resetting the phone or connectivity or microphone issues, so can’t speak to those.

Caller ID on normal phone calls was still missing for me. Since the other issues had resolved, I investigated this further, and it appears to have been solved using the instructions on the Fairphone site here. Why the issue began with the previous OS update I couldn’t say.

Finally, particularly strange re: issue #5551 is that this morning for the first time in weeks I was able to answer an incoming WhatsApp call without my phone crashing and resetting, but this was before I noticed and installed the OS update! Fingers crossed that that continues anyway…

I will report back if that issue or any others recur, but for the past hour or two I seem to have had a functional phone back again. My deep thanks to all who’ve been working on this, and I think I’ve learned my lessons about installing major updates as soon as they’re available!

1 Like

A quick update - unfortunately hotspotting is not working for my FP3 with the latest OS version (1.0-20220622198552). This is a big issue for me.

I can’t confirm whether this is since the original v1.0 update or the more recent one, but am glad to see it’s been raised here (apparently affecting both FP3 and FP3+).

I can confirm the hotspot problem on my Fairphone 3 with 1.0-q-20220622198553-dev-FP3.
Additionally, a network reset doesn’t help.

Switched the slot to go back to the previous 1.0-q-20220527189323-dev-FP3 as mentioned in the GitLab issue and above … OS booted successfully, problem was (before trying the new update) and is (after going back from the new update) not present for me on 1.0-q-20220527189323-dev-FP3, hotspot works.

1 Like