S9+: Unable to update to eos1.4 due to TWRP will not Decrypt Data

  • I bought the Samsung S9+ (SM-G965F/DS).
  • I installed eos through the easy installer.
  • The easy installer installed e1.2.
  • I follow youtube video on how to install TWRP 3.2.1-2 so I can install Magisk.
  • I noticed that there is a system update available: e1.3 and e1.4.
  • I tried downloading and installing both of them.
  • Each time for both updates, when installing, it goes to TWRP recovery but the process of installation stops due to one problem: TWRP asks for password.
  • I have tried entering my screen lock pin. Did not work.
  • I have tried “default_password”. Did not work.
  • I have tried factory resetting to remove all screen locks and fingerprints and hoping to remove TWRP with factory resetting. Did not work.
  • I have tried using ODIN 3.13.1 to install e1.2 recovery over TWRP but ODIN crash the moment I press start.
  • I have tried using ODIN 3.13.1_3B PatcheD to install e1.2 recovery over TWRP but this version also crashed the moment I press start.
  • I have tried clicking cancel on the TWRP enter password screen to go the TWRP menu to go to Wipe, Format Data, type yes, swipe Wipe, reboot to recovery, install no verity dm opt encrypt zip and e1.2 recovery, reboot to system: did not work.

I am not an expert at tech stuff. Can someone please help me remove or replace TWRP back to e1.2, e1.3, or 1.4 recovery instead? I am stuck at the TWRP encryption screen that does not accept any password that I ever created on this device or the default_password. I want to update my device to e1.4 but TWRP unable to decrypt data issue is stopping it from being installed.

Perhaps just try one more thing! I expect pressing cancel to actually pass the default_password. Please try to press cancel and then carry on, as if you had given the expected password.

Thank you for the suggestion. I have tried that also. As I click Cancel to bypass the password screen to TWRP’s main menu to carry on as usual, I realized that there is no data that I can access. I even tried access USB-OTG by using this approach and tried to install e1.2 recovery and reboot to system but it did not install. It seems that TWRP not decrypting data does not permit me to use its features as well or I went about the process of installing incorrectly. I am not tech savy. Please continue to provide suggestions. I really want to resolve this.

I am surprised when you say that you cannot install “recovery-e.img” using TWRP

maybe have you choosed “keep read only” on its first screen ?

You also can create a “recovery-e.tar” and flash it with Odin

Perhaps the no-verity patch (which removes the encryption) didn’t get installed properly? You can try it manually, check this thread:

Why are you using a TWRP from April 2018 for a /e/OS-Q (based on Android 10)?

Magisk can also be installed without TWRP using Magisk-v25.2.apk

:top: topjohnwu / Magisk v25.2

:top: Installation | Magisk

Thanks for trying my suggestion and your feedback. There are some good suggestions already, but to answer one bit of your observation, it is known that TWRP in Android 10 is not competent to deal with the Android default, now in 10, of encrypted data.

With the “cancel option” you get the opportunity to carry on, but only in a way that does not involve messing with data. Not useful to you in the use case you describe.

piero, thank you!! I did not know I was suppose to press “keep read only” on its first screen and it worked!! You saved me from countless hours of trying to troubleshoot this on my own. I had already spent 15 hours on trying to figure it before I asked for help here in this community.

Thank you all for the wonderful suggestions. Now I have e1.4 os and e1.4recovery installed!

My next question is if there is a next update that comes up on software update, is it seamless to just click download and install without losing data? Or does it involved a custom recovery like TWRP to backup data and then install the next eos/recovery update?

Shortly Yes !
Even download is slower using the updater than using a browser.


Considering Magisk,

Maybe it is possible on the Galaxy s9+ as Gianna said.

On older devices, you need TWRP to flash the patched-boot.img after each /e/ update as recovery-e don’t manage .img files, only .zip files (it could be an old patched-boot and magisk do the update of it)

I am trying to figure out how to install Magisk without TWRP. I am following the steps from the Magisk Installation link Gianna provided. I am stuck on where to get the BL, CL, CSC files. I looked into the e1.4zip and it only contains boot.img that is useful. Does anyone know wher I can get the BL, CL, and CSC files for e1.4zip? Or does anyone have a step by step instructions for installing Magisk without TWRP into eos?

piero, what is consider ‘older devices’?

There is no need to take the boot.img included into the samsung firmware here,
just take the boot image included into the /e/OS build

I use to use the Galaxy s4/s5 generation
( I have an external samsung battery-charger plugged in my car, so i always have a full battery in my pocket in advance, and i can use 2 or 3 battery peer day ! )

I think the Question is "ramdisk in /boot partition ? or not ?

S9+ was launched including android 8…

@sfeos please could I ask you if you have been dealing with Android 10, or q, from the start?

I think that maybe you have been distracted by the magisk thing. /e/ does not require or expect Magisk. I find that there are many users online who use the magisk route to get started with custom ROMs. Edit, that is to get started from the original Samsung System. You however have already liberated the device with Easy Installer.

The official instructions for /e/ Edit on Install /e/OS on a Samsung Galaxy S9+ - “star2lte” do not follow this route. Posts on this forum tend to mention Magisk in what I would call the expert area. I do not use it.

Just speaking at beginner level; TWPR is useful for backups, provided you do not intend to change Android version. … but one level up, for instance, I can take a TWRP backup of my device at Q: then I can use TWRP to wipe data, my internal storage stays intact, I can test an R build, wipe data again, revert to Q, restore my Q backup. No data losses expected.

So I already moved out of beginner level!

If you are staying in Q, you do really not need a backup

The simple answer is yes.

As long as all your experience is in Android 10, Q.

You seem to have the issue that Easy Installer has encrypted data – /e/ seems to regard that as a useful default. With a manual install I was able to not encrypt data, so I do not have that issue. I do not believe TWRP will help you fix this. Quite open to contradiction from other contributors here.

As I have been writing, @piero has edited his post above to a well crafted expert tutorial on Magisk!.

However you always want to have some sort of independent backup of anything that is really important if you are experimenting and learning.

Does anyone know where I can get the BL, CL, and CSC ?

For some devices in the official supported list, obtain adb-root access on stock system is needed to install TWRP using the “dd” way. (Install /e/OS on a LG G2 (International) - “d802”)
But you are right, magisk is not mentionned in /e/'s documentation,
but magisk is mentionned in some TWRP’s documentation. (Samsung Galaxy S10+ (Exynos))


1 Like

Thank you for providing that link to How to Install Magisk without TWRP in 2022 - Rootmygalaxy.net. I followed it up to

  • Instructions was to ‘Load BL file, CP file, and HOME_CSC file from the extracted firmware to BL tab, CP tab, CSC tab.’
  • e1.4 zip does not have BL, or HOME_CSC file. It only has boot.img which I used 7zip to convert to boot.tar to upload to phone to be patched by Magisk and then transfer to pc to upload to Odin as the AP file.
    *Once I uploaded only the AP file (magisk patched.tar file) I clicked Start button.
    *Odin’s log show it being stuck at SetupConnection…
    *I did use the latest version of Odin v3.13.3

What do I do to fix being stuck at SetupConnection? Do I need the BL, CP, CSC file that e1.4 zip does not have to continue?

This should happen if you go to Settings > System updates > top right 3 dot menu > Preferences > Update recovery.

The position of this toggle changes with Android version.

When update recovery is selected, we expect TWRP to be replaced by the /e/ Recovery to match the /e/ version being installed as the /e/ OS update happens.

If you originally used Easy Installer, you are likely to be on a stable build (reference: Different Build Types). You should avoid lightly changing from Stable to dev channel (or vice versa).

On Android 10, this can be confirmed from

Settings > About phone > Android version > /e/ OS version – Long press on /e/ OS version to copy to clipboard.

Thanks for the suggestion. I have replaced TWRP with e.14 recovery already. Now I am hoping someone can help me install Magisk without TWRP if that is possible for S9+.

S9+: Unable to update to eos1.4 due to TWRP will not Decrypt Data - #13 by piero


Why not install TWRP after each /e/ update to flash the patched-boot and then replace it by recovery-e before each /e/ update ?

OR simply keep TWRP and just “dirty flash” latest e-build over the precedant instead of perform OTA update ?

which TWRP version do you recommend that does not have data decryption issues with the S9+?

Maybe None,
it is the reason why it was (provisoiry ?) abandonned.