Samsung Note II L900 Sprint phone purchased around 2013

I’ve followed the instructions the best I could and I get a bit e with a bouncing dot underneath.
Nice people tried to give me advice. Someone said I needed to reboot after data format.
I don’t know what the sequence should be, or if it matters. I think I’ve tried them all.
For this last try I did data format, reboot into TWRP (recovery), and then wipe Darlvik, Cache, System.
Still boots into an e with a bouncing dot.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Samsung Galaxy Note 2 (SPH-L900) for Sprint isn’t an officially supported device by /e/ OS.
Which /e/ OS from where did you flash?

it is this device and used that rom

He has checked the device code via adb and it was showing t0lte.

1 Like

Use Heimdall commands instead of fastboot on a Samsung device (Install latest /e/OS ROM on your OnePlus 5 aka. cheeseburger using GNU/Linux)

([HOWTO] Install /e/ on a Samsung smartphone with Windows easily)

I’m not sure what you are suggesting. I used heimdall to put TWRP on the phone. Is that what you’re talking about?

I wasn’t sure what you were suggesting, but I just tried again following those instructions and used sideload. I still have the bouncing dot.

I mean this how to i advise, has been written for another device…

The /e/ documentation for Samsung Galaxy Note 2 (LTE) - “t0lte” indicates Models Supported


Other models are not supported ~ SPH-L900

LineageOS Wiki Info about “t0lte” does’ot specify a model version at all. Well, we know that this dokumentaions don’t always contain exact information.

The /e/ documentation links to TWRP for t0lte, TWRP for Samsung Galaxy Note 2 N7105, Code Name: t0lte

The StockROM firmware for the SPH-L900 (cdma) (SPR) is specifically for “Spint” one of the four major US carriers. Also TeamWin has a special TWRP for Samsung Galaxy Note 2 Sprint, code name: l900

So there are little inconsistencies and the “I still start in an e with a bouncing dot” must have a reason.

Okay, because …

adb shell getprop ro.product.device
Result: t0lte

… I would proceed as follows:

1… reflash stockROM Android 4.4.2 L900VPUCOH3
2… install TWRP for Samsung Galaxy Note 2 Sprint
3… first flash an older version of /e/ OS, for example …


… and then make anOTA Update.

Tags: Install /e/ on Galaxy Note 2 LTE GT-N7105
Help to fix problems in i9300
Failed to install TWRP on Galaxy S4

Hi all,
new forum member here, trying to get my Sprint Note 2 L900 working with /e/.

I understand that the L900 is not officially supported but I have the device and I’m not using it as my daily so I thought it would be useful to try it out per archje instructions above.

  1. downloaded the e-0.7-n-2019062514554-dev-t0lte zip file mentioned above.
  2. had to modify the updater-script to allow for my device which is coded as ‘l900’
  3. the results from TWRP install are as follows:

E1001: Failed to update system image
Updater process ended with ERROR: 7
Error installing zip file ‘/external_sdcard/e-0.7-n-2019062514554-dev-t0lte’
Updating partition details…
… done

If anyone has feedback or an idea of what I might try that would be most appreciated.
I’ll be happy to report back any findings.


Hi @spike, welcome in the forum :slight_smile:

for your information, there is an unofficial build on Pie made for the i9100. I don’t know if it could be useful.

To solve the error 7 issue, use TWRP 3.3.1 instead of the 4.0.0.

Thanks for the follow up @Anonyme
Thanks also to @archje

I switched to TWRP 3.3.1 (from 3.4.0)
I could not get the i9100 unofficial to flash so I tried again with my modified version of the “t0lte” ROM mentioned above. (e-0.10-n-2020081467789-dev-t0lte modified)

And It Worked!

When it had previously failed so that was perhaps due to downgrading TWRP to 3.3.1 or the fact that the new instructions included the data wipe (Wipe -> Format Data -> Type [yes]) or both.

Thanks and if anyone wants detailed step by step instructions I would be happy to provide, just reply or send me a PM.


1 Like

I hat the same problem quoted below with the samsung s8 (SM-G950F):

and i could solve it by using an older TWRP ( instead of

Thanks a lot for sharing @spike, im super happy that the installation of /e/OS finally worked out :blush:

@spike If you don’t mind, what did you do to modify t0lte rom - " e-0.10-n-2020081467789-dev-t0lte modified"? It would be great if you can provide step by step instruction. In USA, sprint sph-l900 is the only remaining version of Note 2 which is still usable as mobile device, as other carriers (Verizon, Tmobile, AT&T) have phased out or nearly phased out all non-volte devices. It would be good to document how to make t0lte rom work on sph-l900. thanks