Upgrade Galaxy A3 (2016) to Q version e-0.15

Having installed the unofficial test version e-0.10-p-2020081067156-test-a3xelte on my wife’s phone nearly 9 months ago - which was working with few problems - I decided to upgrade her device (SM-A310F) to the latest Q-build of /e/. Following the official upgrade instructions I noticed that it appeared a simple operation which consisted of dirty flash using the already-installed TWRP recovery I had put on it.

As the phone was not encrypted the instructions said to simply sideload the e-0.15 zip file directly to the device. As I had prepared a backup on a USB stick with the file on it, I decided to flash it via OTG using my TWRP recovery. The installation flash ended with the usual “successful” message and so I rebooted into the system which took some time as I had cleaned the dalvik cache just in case, but when Android started an unexpected warning popped up to say that there was an “Internal System error” and that I should inform the manufacturers about the problem.

In fact, on closing the pop-up Bliss started normally and I had all the usual apps as well as those that were previously user-installed. I tried restarting but the same pop-up reappeared and now I ignore it as after trying most of the apps, checking that the phone worked it all seems to function normally. The only peculiar aspect of Bliss was that the Phone icon had been moved to the end window and I had to put it back in the bottom tray.

My only question is what will happen after an OTA update? Will the same error message keep recurring? I am tempted to try doing a “clean” re-flash, which means wiping all user data and reinstalling everything, but as the need for family communication is pressing I shall wait for a calmer moment when I’ll have time try this procedure. I don’t know if my experience is exceptional in that the upgrade was from a test build of the Pie version, but it might be useful to modify the upgrade instructions if this happens to others.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Thanks for the feedback @Grendel …was waiting for a user experience with the Q A3 builds.

Hi @Manoj, happy to be of use. Just wondering after looking at the Upgrade instructions which contain this warning:

Caution: Before following these instructions please ensure that the device is on the latest Android firmware.
For example to upgrade to /e/ Q the Android firmware should be Android 10 and for /e/ Pie it should be Android 9

There is something illogical here in that for the SM-A310F there is no Samsung firmware on either Pie or Q as the last official one I can find is still on Nougat. My upgrade from the test build of /e/ which was on Pie is the only logical upgrade route unless you’re coming from a Lineage build which now is offered with Android 10. So does this mean that the only safe route is by re-flashing Lineage 17.1 and then doing the upgrade?

Their instructions suppose you have TWRP and they tell you to do both a data wipe and an Advanced wipe of Cache & System before sideloading their zip file. Although they do provide an update script, it doesn’t work for upgrades!

The Samsung Galaxy A3 (2016 Exynos) - “a3xelte” (SM-A310F) has had a buggy /e/ OS 'O’ero 8.0.0 history. Bootloops without end, despite repeated updates.

To the /e/documentation with the notes

Warning: Downgrading Smartphones already on Android Q or LineageOS 17.x to Pie or other OS can cause instability or at worst brick some devices

Caution:Before following these instructions please ensure that the device is on the latest Android firmware. For example to upgrade to /e/ Q the Android firmware should be Android 10 and for /e/ Pie it should be Android 9"

I say nothing more than - the information is simply wrong and therefore erroneous. It is a wasted effort to go into it further.

First I wanted to make a “dirty flash”. During the TWRP nandroid backup, after the very clear and understandable description by @Manoj, which is suitable for every user, even for “Mom and Dad”, I changed my mind and did a “clean install” to minimise possible sources of failure.

Right at the first boot this message shows up:

Android System
There’s an internal problem
with your device. Contact your
manufacturer for details.

The message does not show any further effects. But: The current LineageOS-17.1-for-microG with Android Securtiy Patch Level 5 March 2021 does not show this message!

A valuable feature is that the microSD card can be formatted as an internal memory expansion. In this way, the scarce “16 GB internal storage” can be significantly increased and apps may also be swapped out to it. My 64GB U3 V30 microSDXC is then displayed, among other things, once as a total storage size under “Storage” (8% used - 73.32 GB free). It is strongly recommended not to take the SD card out of the slot again. The risk of data loss is very high.

Connected via WLAN, the system no longer shuts down and the annoying boot loops are no longer present. The SIM card, inserted into the running system, is recognised immediately, the SIM pin is queried and a minute later my provider responds with an SMS and sends me the optimal system settings

The first impression of /e/ OS “Q” on the “a3xelte” is good. The only thing that remains to be clarified is why the message “There’s an internal problem …” continues to be displayed after every restart. LineageOS 17.1 does not know this message.


The fact that the A3 2016 is now finally ready for use under /e/ OS not only pleases me but I think even more /e/friend @Rikare the builds for this week online already somewhere?

Thanks @SuzieQ for your useful remarks on this “internal error” which seems to have no effect luckily. I also added a comment to @breversa message about having the same warning on installing on a Galaxy A5.

It’s curious that these older Samsung devices have the same problem if, as you say, the Lineage version does not. Since /e/ is based on Lineage, one wonders how it happens, if they have a script that gets rid of the warning since my guess is that it is built into the original AOSP to warn users of possible bugs when the upgrade is made from an earlier version. Why would they say “contact your manufacturer”? Lineage doesn’t make cellphones as far as I know, so it must be aimed at all manufacturers to tell them to upgrade to a more recent Android. Google putting pressure on builders as they are doing with the move to A/B devices. Samsung is in the firing line!

1 Like

I did the install, writing from it now.

Not ready to write it up.

The error looks to my untrained eye like a minor partioning thing. I could not use /e/recovery. I hazard to predict that a working /e/recovery will fix the issue. :smiley:

I used TWRP 3.5.1_9.0, formatted and wiped in the classic way, both at /eOS ‘Q’ and at LOS 17.1:

Advanced Wipe
Format Data
Swipe to Factory Reset

The fact is proven: LOS 17.1 runs without problem, /eOS is running with failure message.

This post has not closed yet so for lack of a better place to put a small bit of news concerning the new e-0.16 update that showed up recently but is dated April 24 if one can go by its name, I thought I’d add it here since the warning pop-up about an “internal problem” has not gone away. As noted here and elsewhere with other devices of the A series, clicking on cancel allows you to ignore the warning and all seems to function as before.

However, I’d be curious to know if @aibd’s suggestion that using the e-recovery actually gets rid of this. My device still has the original TWRP that I used to install and upgrade /e/ to the Q version.

In case this unresolved post leads to misunderstanding, I should respond and say that my prediction was nonsense should only have pointed to the failing e-recovey issue being “likely” linked to the main issue on the opening Home screen! The bug report is here #2840. I tested a fix (mentioned there) and a real fix is “in the pipeline”.