Galaxy S9 'starlte' + /e/OS 'Q' dev AOSP Android 10

/e/ OS ‘Q’ doesn’t require a rooted device to work properly. What makes a newbie root his device?

1 Like

Misunderstanding, @SuzieQ, misunderstanding. I am guilty of it as well (on my S6) as it was my understanding that this was a necessary part of the process. Of course, my understanding was incorrect, but there it is. :slight_smile:

Yup! Exactly how I felt after the 5hrs. It was like literally all I had to do was install TWRP and sideload /e/OS Q. Instead newbie brain said TWRP will not install without root privileges even though it was already installed to root the phone in the first place.

Just bookmarked and saved that link to pdf for next time. Thanks. I completely missed that guide during my search yesterday

:point_right: That’s what makes learning fun, when success triumphs at the end, isn’t it?

1 Like

Okay Tom, thanks for sharing your experience in clear presentation way.

I’ve tried several installation variants, but certainly not all of them. For example, when flashing /e/ OS ‘Q’ on the Galaxy S9 and S9+,

I did not use no-verity-opt-encrypt-6.1 (exception: GSI ROM installation),
but successfully already used TWRP 3.5.0_9-0

On the Galaxy S9+, I also successfully installed eRecovery as an alternative.

1 Like

The failure message ‘Error’ with Eroor code ‘1’ can have several causes. The lines before the visually prominent ‘ERROR 1’ contain clues to this. What was the text hint?

I’ve just installed on a Samsung Galaxy A3 (2016) ‘a3xelte’ the TWRP Recovery 3.5.0_9-0 along with LineageOS 17.1 version January, 5th 2021 to then update with an OTA update to the current LOS 17.1 version of 7.2.2021 with Android Security Patch Level 5. February 2021. TWRP 3.5.0_9-0 did its job without any problems and did not give any error messages. So much forConclusion: twrp-3.5.0_9" not being suitable for devices with Android 10.

Hi @TomK, you may certainly be correct (it may be intended for devices running less than Android 10, I do not know that!), but I just verified that I have twrp-3.5.0_9-0 loaded on my S9, which I used to flash /e/OS Q without incident. Not sure what may have changed between twrp sub-versions “-0” and “-1”…

Also, I did not use no-verity-opt-encrypt-6.1.

Just some anecdotal evidence which you or others may find helpful.

1 Like

Thank you all for this nice thread. I am thankfull for all the beginners questiones and those who shared their knowledge.

I proudly made the upgrade and became a beginner+ and like to give back some information.
I installed /e/on starlte in december with the easy installer.
Before upgrading I made several backups with nandroid and adb.
Then I tried to upgrade TWRP and ran into the 'waiting for device’s error. Flashing recovery with Odin did the job.
Searching for a Samsung firmware, some sites require an account others are so damned slow … .
Newest vs. older firmware? Somehow I decided to go with the newest one and to try my luck. Downloaded the German DBT version from January and flashed it with the newest Odin version. Samsung was starting and everything seems to be fine.
Flashing TWRP with fastboot still doesn’t work. Okay but than flashing TWRP with Odin hasn’t worked either. Mmmh, I couldn’t see an error in Odin but it wasn’t obviously not I installed. Several attempts with flashing the firmware without any changes. Searching the web I saw in samfw that they pointed to another Odin Version. 3 o’clock in the morning I thought, come on give it a try,
installed the older Version 3.13.1 of Odin, flashed firmware and then successfully flashed TWRP.
After installing /e/ I was so happy to see the e splash screen. It started to encrypt my phone immediately. It seems that this is standard now. Rebooting into recovery I was asked for a password which I don’t have. But somehow it is possible to get into the standard screen and to restore the data partition from my nandroid backup.
Everything (except some few apps) was there and the phone is up and running without any problems.

@littlejoa, thank you for your vividly described experiences. This makes reading fun. We were all once beginners and I still learn every day with pleasure to it.

Flashing with fastboot commaandos generally does not work on Galaxy devices because Samsung does not support it and has its “own language”. Whether Odin 3.13.1 or 3.14.4, all versions work for me.

Android 10 and LineageOS 17.1 encrypt by default. Yes, it’s now mandatory. It is intended to be a security feature. However, there are ways to disable this mandatory encryption and enable it only when needed. The TWRP password prompt can simply be ignored by switching back to TWRP Main menu.

Now all /e/ OS ‘Q’ users can hope that the Galaxy S9 / S9+ will be supported by /e/ for a longer time - because the Lineage-Team has officially stopped support unexpectedly for me.

1 Like

How long will the Samsung Galaxy S9 still be officially supported?

An article on SAMMOBILE talks about “Samsung will continue to provide security updates for another year. The Galaxy S9 and Galaxy S9+ are currently on a monthly cycle for security updates. They will eventually be downgraded to the quarterly cycle.”

My sources are talking about not expecting the once premium devices to get a major upgrade to Android 11 yet. The Android 10 update with OneUI 2.5 that was distributed last year once again brought powerful improvements on the firmware level as well. Thus, I was able to transport my Galaxy S9+ into the Android 11 spheres via GSI AOSP Android 11 without much effort.

My sources, who have very often been right with their predictions in the past, quote numbers in contrast to SamMobile: Android security patches are still expected monthly until the end of 2021 and quarterly thereafter until the end of 2022.

The fact that /e/ can build OS ROMs without lineage /e/ and also backport security patches from higher Android versions was proven by /e/ with the Samsung Galaxy S7 / S7 Edge under Android 7.1.2 Nougat. By the way, a few enthusiasts in the Lineage community continue to do so.

All in all, the signs are good for these two Galaxy’s - also because of their Treble GSI compatibility and because there are and always will be enthusiasts like the GSI genius phhusson aka Pierre-Hugues HUSSON, who build an absolutely Google free GSI code and make it available as open source.

1 Like

Hi @SuzieQ. Could you tell me where is the magik to ‘Disable force encryption’ ?

When using ‘adb reboot recovery’, TWRP is asking me for a decrypt password I don’t own, and I’m stuck… (I’m trying to edit /system/build.prop to enable VoWifi…)

Please try this first:

I’ve tried to upgrade my /e/ S9 device to Q but run into a problem. As suggested I’ve first upgraded the firmware to Q using the firmware from sammobile (build 22 jan 2021) This was successful. After that I’ve followed the instructions from Patching the device failed however since this wasn’t mentioned in the I thought this might not be needed. Upgrading twpr was successful however when I want to sideload /e/ using adb sideload I get the next error:
serving: ‘’ (~0%) adb: failed to read command: Success
What am I doing wrong? thanks in advance.
Edit after re-reading the instructions it seems I missed the Vendor updates. Currently downloading continues fails for the vendor but will give that a try first.
Edit2. vendor sideload gives the same error.
serving: ‘’ (~0%) adb: failed to read command: Success
Is this due to the fact patching failed or is there something else wrong?

The message 'failed to read' is an indication that adb sideload cannot find the file ''.

For simplicity, try the following (there is more than one possibility): copy the file ‘’ to the same /directory folder where the adb.exe tool is located.

Installing is no longer necessary under Stock Android 10-Q. It comes from /e/OS 'O’reo 8.1.2 times.

With the Stock Android 10 upgrade, the /Vendor partition is also updated and harmonizes perfectly with /e/ OS ‘Q’. The manual installation of /eOS ‘Q’ works flawlessly, the one with the /e/ays installer (v0.12-beta) is currently still massively buggy.

First of all many thanks for all the support you provide here in this ticket SuzieQ. It’s much appreciated. I’ve got one additional question about the instructions before giving it another try. Since patching the device failed by me is that also an old instruction or is that still needed.

Edit. It seemed the culprit was using adb in linux using a virtual machine. Although adb logcat etc. works apparently adb sideload failed. After installing adb in windows sideloading was successful. Thanks again for your support.

Hi, I’m trying to flash twrp on a friend’s s9+ but for some reason, I keep getting an error saying “only official released binaries are allowed to be flashed(recovery)” in Odin 3.13.1 to 3.14.1.
I think the phone was upgraded to Android 10 over-the-air. I am currently downloading the XSG-G965FXXSEFUA1 firmware from Sammobile 8hrs more to wait to try and re-flash Android 10 on the phone.

However, just wondering if anyone had had this issue and if there was anything I could do to try and fix the issue while the firmware is still downloading? Or if it is even a firmware issue rather than hardware?

For me this means: OEM UNLOCK is not yet activated.

Tip: Check the device status.

Strange, it says OEM unlocking is activated. Though I’m now wondering if it truly is activated. When I first factory reset the phone, and enabled developer mode the OEM unlocking option didn’t show up at all (not even greyed out) until I inserted my sim card into the phone. And now even after re-flashing the Android 10 firmware it is still doing the same thing.

I’ll re-flash again and possibly try to downgrade to 8 or 9 if that is even possible