Samsung Galaxy A3 2017 SM-A320FL/F/Y a3y17lte

A3 is the smallest phone with his caracterictics it’s why it’s a good idea to promote it. It’s a pecial phone (at least it’s my opinion :wink: )

ROM OS Version: 9.0 pie
ROM Kernel: Linux 3.x

XDA link

Source Code: https://github.com/McFy49

There’s no known issues on Lineage 16.0 and it’s maintained by comunity

4 Likes

It seems this is a duplicate. The first mention to support a3y17lte (sm-a320) can be found here:

Yes it’s a duplicate I wanted the title more clear about which models and follow the request device’s specifications.
Perhaps I made mistake, Surely it’s a good idea to mix them.
An appropriate title with different Rom available for build should be good also

The Samsung Galaxy A3 2017 has received an unofficial version of Lineage OS 17.1 developed by MartinYTCZ, XDA senior member on the XDA forum.

Hi @itsclarence, you are a ROM building enthusiast. Wouldn’t that be an appealing task for you to build a /e/ROM e-0.13-q-? @harvey186 GSI ROM eOS-Q-Full-_arm64_bvS works well on the ‘a3y17lte’.

Enjoy testing…

You are incredible, @itsclarence(!!!). Thank you … :))

eos014itc

The installation and booting process takes place as usual without any problems. Wi-Fi surfing works, but phone calls and text messages do not work because the SIM card is not recognised. Even at start-up, the SIM pin is not requested. With the brand new GSI ROM from @anon26953564, the same Galaxy A3 2017 recognised the SIM card. Can you please find a solution!

Please try again…

Yes, I like to do that, although immense problems have arisen.

Now, the A3 2017 starts up to the maximum e-animation and the white dot bounces without end.

A32017_e-014Q

In TWRP, I made a Format Data to free up the /data partition for a factory reset. Unfortunately, this did not work.

So I quickly set up the A3 2017: Stock Android 8 Oreo, TWRP 3.3.1-0, alternatively TWRP 3.4.0-0. Both times error message in TWRP.

Now installation via TWRP 3.3.1-0 and TWRP 3.4.0-0 as well as adb sideload. Both times error message “Updater process ended with ERROR: 7

Especially noticeable was the extremely long installation time via abd sideload. It took at least 60 seconds until the first 1% was displayed, and about five minutes until the end of the installation.

Now installation of unoffical LOS 17.1 via TWRP 3.4.0-0. Everything runs as usual, LOS 17.1 boots without any problems and runs smoothly.I am at a loss, and you?

Maybe you had a corrupted download…
I uploaded the file also on AFH now. Maybe another download and effort. Or maybe wait until another user is willing to test…

I have not left untried, reflashed my A3 2017 several times with Stock Android 8.0.0 Oreo, tried TWRP 3.3.1-0 / 3.4.0-0 and also OrangeFox Recovery R11.0_1-Stable - but without success.

I don’t understand anything anymore - because with Lineage-17.1-20200830-UNOFFICIAL-a3y17lte by MartinYTCZ everything works.

This build will be my last effort for this device. It’s given me several errors the last few day’s (and headaches)
If this one doesn’t boot normal it’ probably because of the kernel. If you can find another kernel, you could try and flash that one.

1 Like

I did not manage to get the CustomROM to work despite umpteen attempts. I’m back to GSI eOS-Q-20201225-UNOFFICIAL-treble_arm64_bvS. If the opportunity arises, I’ll try again on another A3 2017.

1 Like

New devices, new luck? Not at all!

I took a completely different A3 2017 with fresh stock Android 8.0.0. First I installed e-0.14-q-20201216-UNOFFICIAL-a3y17lte, then e-0.14-q-20201220. The ‘a3y17lte’ booted up to the Samsung logo - no further. Out.

a3y17lte_1

Then I installed one after the other - successfully: LOS 15.1, LOS 16.0 and from another ROM builder LOS 17.1 UNOFFICIAL-a3y17lte.

a3y17lte_2

After that I installed again e-0.14-q-20201216 + e-0.14-q-20201220 - without success. The ‘a3y17lte’ booted this time up to the e-animation - but no further. This is very strange, isn’t it?

It would be cool to see /e/ on the A3 2017. It is the only new android phone that isn’t huge, and therefore would make a great addition to the lineup.

hello SuzieQ. It’s my first post on the community, please be kind.
I’ve got a a3y17lte and have troubles with custom ROM since i’ve installed a treble ROM on XDA (no more SIM card detected).
I understand that you have found a version here (eOS-Q-20201225-UNOFFICIAL-treble_arm64_bvS) which works fine (sim car detected). I would be happy to install it but i don’t understand .xz extension. Must I extract the img file and rezip to *.zip ? Not clear for me, i expected to have a zip file for adb sideload.
SO, could you tell me which file to get and how to install it?
I could have my favorite phone back.

found solution (flash img in TWRP), I forgot this possibility.
Nevertheless, my SIM card is not recognized with eos-Q-20210225-UNOFFICIAL-a3ylte.zip.
Did you find a img that works ?

Hello @isaac, why are you afraid that I might be unfriendly? Treating each other with respect is very important to me. I only become unfriendly if someone has done that before me.


GSI ROM are ingenious on the one hand, but very error-prone on the other. Especially when the source firmware (stock Android 8-Oreo) and the GSI are Android 10 ‘Q’.

On top of that, the A3 2017 ‘a3y17lte’ does not come with Treble Project compatibility from the factory and the device has to be treblezied afterwards with know-how & tricks. This brings some additional error sources into play.

Customized customROMS aren’t only easier to install, but usually also more stable in use. It would be nice if there was a consistently working /e/ OS ‘Pie’ or ‘Q’.

Thks for these answers.
I’ve reached to treblezied my a3 pretty easily. Seems to be A. Since then none of Roms I’ve flashed recognized Sim card and it is the only problem encountered. Maybe it’s a APN config XML file missing. Going to dig this idea.
Is it possible to de-treblezied the phone to check if it’s a hardware bug ?
.

@isaac , why don’t you answer my question? You also want me to answer your questions, don’t you?


You guess it »Seems to be A.« ‘a-only’ ROMs cause my ‘a3y17lte’ to bootloop. Well, I know defeinitively that my A3 2017 SM-A320FL a3y17lte status is ‘a/b’ because whether I use version eOS-Q-20210225-UNOFFICIAL-treble* or the current version eOS-Q-20210214-UNOFFICIAL-treble_arm64_bvS - it works.

That twoTrebleCheckApps show mixed results is well known. Through trial and error I got to the goal:

I just inserted a SIM card into the ‘a3y17lte’ that is turned on.Immediately the system reacts and asks to enter the PIN. No sooner said than done. Now the ‘a3y17lte’ asks me to reboot. Okay, done. Now my provider is displayed, the LTE is ready for use. A control call confirms that it is ready to receive. Calling another phone number is also possible.

Résumé: The most important function of my cell phone Galaxy A3 2017 works as it should: I can make calls via LTE and GSM. Calling via SIM data-package and WLAN also works.

Thks a lot, that’s it : A-only, I’ll try to flash both to check that point.
I’ve read several threads with similar problem (no sim card detected whatever you flash). Not easy to resolve, several possibilities.
For the answer to the question, I’ll guess that I was inviting you to be patient if my noob questions were irrelevant :smile: