[UNOFFICIAL BUILD] Sony Xperia XZ2 Compact (xz2c)

Here’s an unofficial Q build for this device built from the latest v0.14.2-q tag

Note that this build is not tested in any way: I haven’t even flashed it, because I don’t own this device.

Please take a backup of your current setup, and use at your own risk

Check the integrity of the downloaded file by running

  • on Linux
    md5sum e-0.14-q-20210126-UNOFFICIAL-xz2c.zip
  • on MacOS
    md5 -r e-0.14-q-20210126-UNOFFICIAL-xz2c.zip

The output should match the MD5SUM number 4b42e65960d4e7ae5c124f8dd5c7d77a

If you have any problems flashing this build, this thread may be helpful:

3 Likes

Hope it’s fine if I share a new buid here. Unofficial build 0.16-q:

My device is acctually a single SIM (H8314) but everything works, build is for dual SIM (H8324).

Flashing worked with thread from Markus which is above, I used a Lineage OS Recovery not TWRP:

Linux md5sum: md5sum e-0.16-q-20210419-UNOFFICIAL-xz2c.zip

Output: 37800990aef8693818db952e0182e04b

3 Likes

Here’s the latest build, I used sideload to test it on the device. Exposure Notification installation is not working on my device, even after I deleted storage off Apps app which seems to be to usual workaround. Everything else worked.

@petefoth Are you able to change the topic name? Searching it works only with ‘XperiaXZ2’ I guess.

1 Like

I can’t change the title. Maybe @Manoj can do it?

Pl let me know what do you want to change the title to

1 Like

[UNOFFICIAL BUILD] Sony Xperia XZ2 Compact (xz2c)

Thanks.

Hi @mihi does /e/ get to use the full 19MP of the camera?
Thanks.


Hi @mike_from_ireland this the way how to check it…?

1 Like

As usual own risk, and so on… EN again not working or able to download form Apps, trying to find correct apk to install it. Will post it here

1 Like

Yes that’s it, great to see /e/ can use the full camera 19MP. Thank you. Very tempted to get a XZ2C as my daily driver and Z5C as backup.

Its such a great device IMO. a pitty there are only a couple device in that size region…

1 Like

Had to create a new build from tag 0.18.2-q, then I was able to update microg so EN would work:

Use the “GmsCore-test.apk”

I use the device as my dailydriver. Only thing I experienced (had it with 0.17 before too, but now more than before) is that, the screen is frozen and no swipe or button works, after screenlock it works again.

Also I didn’t manage to change to gestures, even with Bliss (it worked with my spare FP3 on the stable release).

Glad to hear your Feedback

1 Like