'easy-installed' new Fairphone 3 doesn't connect data, on a SIM that does work elsewhere

Almost all is in the title. I just bought the last Fairphone 3 in my french Orange shop, with a new SIM too. This SIM does work with data on my old phone. Now, I installed /e/ on the Fairphone and try the SIM. Result is I can place and receive calls but no data. Any app I try, like k9mail or just the plain browser, says ‘no internet connection’.
I run the latest /e/ version for Fairphone, at least that’s what the /e/ updater says (when connected in wifi)
of course I have data activated.

what can I do?
where can I find an exhaustive setup to check mine against it?

I am in significant trouble since, if I go to Orange they will detect I modified the Fairphone original system and will just tell me I voided the guarantee…

TIA!
H.
(Answers OK in French too!)

[edit] extra info : the phone also doesn’t recognize the SD card of my old phone, proposing to reformat it

You should check the APN settings in /e/, these are responsible for giving you mobile internet. Orange have to have the correct ones somewhere on their website, perhaps here? … Configurer un APN internet et MMS - Assistance Orange
Or you could try the marginally different settings given here … [LIST] APN Values for Service Providers

Settings - Network and Internet - Mobile network - Advanced - Access point names

You can restore Fairphone OS if you like … FP3(+). Install Fairphone OS offline – Support

Can happen.
Don’t format it as Internal Storage, though, use it as external/portable storage to avoid possible serious trouble (Apps not able to use storage, storage getting messed up = data loss, reboots perhaps).

1 Like

thank you @AnotherElk for this very fast reaction!

  • the Orange settings iyou point me to ndeed are the ones I have. I tried to change the only variable one (swaping ‘orange.fr’ with ‘orange’ but this didn’t wok, even after rebooting
  • thank you very much fot showing me I can restore the original system. If all goes wrong I’ll do that, even just to check that original setting works on the phone.
    But if I don’t find other clues I’ll try to re-install /e/ , to begin with. But as this is a long process I may not be able to restart it before monday…

Since you had to power down the phone and reseat the SIM card already to test it in a different phone, here’s something else from a forum search …

1 Like

Thank you Anotherelk -I for one would never have found the command to reset the wifi, mobile and bluetooth! But even after a reboot, this doesn’t work.
Two quick questions :

  • if I relaunch the easy installer, will it overwrite my “already-/e/” phone properly?
  • if all goes wrong and I want to reinstall the original ROM you pointed me to, will the easy installer be able to do this? (because I have just zero experience to proceed otherwise -on Debian here)?
    TIA!
    Hervé

Having the same problem with my Fairphone 3. The only way I get the SIM to build up a mobile connection via LTE is following:

Change the settings “network & internet” > SIM name > “extended" or something like that, in German “Erweitert” > “preferred net type” to “2G”, then leave the settings and go back and change it back to “LTE”. My Fairphone connects via LTE then.

Changing APN settings and resetting network preferences and so on didn ot help at all.

3 Likes

It should.

No, it just installs /e/.

Well, there’s this here … [HOWTO] revert your Fairphone 3 with /e/-OS back to Stock ROM using Debian based GNU/Linux … but this guide uses a community-packaged (= unofficial), very outdated Fairphone OS version. Better than nothing if all else fails, but whether this is really better than to follow the detailed official guide? I don’t know.

If you happen to have Fairphone Angels in your vicinity, they might perhaps be able to assist you in person … 👼 The Fairphone Angels Program and Map (Local support by community members) - Local - Fairphone Community Forum.

1 Like

Thank you @AnotherElk !
I tried to contact a local angel; I didn’t find one around here but there seems to be some in Paris, so I wrote to the dedicated address explaining I’ll be there two days from now.
In the meanwhile, I restarted the full easy-install process. It unfolds almost up to the end, but, like last time, it hangs while “creating my e.email account” (waiting indefinitely)…
Could you tell me if

  • it is safe to change the address required and retry continueing in the installer?
  • it is safe to quit the installer there and just continue with the phone boot?

TIA!

P. S. in the terminal (from which I launch the installer with ‘snap run easy-installer’) the last comment line I see is:

at java.base/java.lang.Thread.run(Unknown Source)
12:36:36.881 [JavaFX Application Thread] INFO  e.e.i.c.s.EAccountController - onCheckMailBtnClick
12:36:37.177 [pool-3-thread-1] DEBUG e.e.installer.tasks.AskAccountTask - call(), response.body() = <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx</center>
</body>
</html>

Exception in thread "JavaFX Application Thread" java.lang.NumberFormatException: For input string: "<html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx</center>
</body>
</html"
	at java.base/java.lang.NumberFormatException.forInputString(Unknown Source)
	at java.base/java.lang.Integer.parseInt(Unknown Source)
	at java.base/java.lang.Integer.parseInt(Unknown Source)
	at ecorp.easy.installer/ecorp.easy.installer.controllers.subcontrollers.EAccountController.setResultInstruction(Unknown Source)
	at ecorp.easy.installer/ecorp.easy.installer.controllers.subcontrollers.EAccountController.lambda$onCheckMailBtnClick$5(Unknown Source)

OK, I tried the two options above. No way.
The FP3 boots on /e/, without e.email account, then I allow wifi connection, which allows to check my /e/ version is the latest, then once I switch wifi off, ‘no internet connection’…

I always installed manually, I don’t know much about this. I never bothered to set up an e.email account either, so just going by that the account is not important for running /e/ I personally would quit the process and hope the email thing is a last, unimportant step.
@Ingo_FP_Angel, any thoughts?

The step to create an e-email is optional. For the phone and /e/ OS on it, it doesn’t make any difference if that step in the installer is skipped or didn’t work. Which means you don’t need to re-run the installer at all.

In case you do want an /e/ account, you can always create one via their website (like those people who manually flash the OS and do not use the installer).

Independent of how you created your /e/ account, you can add it on the phone either during the first time setup wizard or later via Settings > Accounts.

1 Like

Thnk you, @Ingo_FP_Angel , @AnotherElk -at this moment, as nothing else works, I applied the method described in ‘staging OTS disable’ to try the next build version, and am patiently waiting for the second progress bar to finish…
[edit] I’m now rendered with /e/ version 0.19-20210917136090. Still no way. Being with Orange, I tried both the ‘orange france’ and the ‘orange internet’ presets. With an Orange SIM that definitely works when I put it back inside my previous phone…

[edit] at this moment, retrying to flash the current version, without the SIM inserted, because I read somewhere one should remove it, while this is not indicated in the easy-installer process… OK. Back to 0.18… Some initial settings vary (for instance, the phone now doesn’t detect I’m in France, short of the SIM of course) but still, just no internet connection… The GSM network calls itself “Orange F” apparently, which does not correspond to any preset in the access points. But I already tried earlier on to select ‘Orange France’ or ‘Orange internet’, to no avail… And indeed clicking on either of them doesn’t work better, even after rebooting…

End of the story : I moved my SIMcard from slot 1 to slot 2 : now it works. Is this normal??
Or else is there a setting somewhere saying ‘do connect internet through SIM2 even if only SIM1 is present’??

2 Likes

That’s weird !

If you can borrow a friend’s SIM for some minutes, try to insert it at SIM #2, moving yours at SIM #1.
Then, you may be able to choose what SIM is to be used for data, and see if this setting is kept after removing SIM #2.

2 Likes

Hello,

I had the same problem and work fine with SIM in second slot too. Thanks

2 Likes

Thank you @smu44 , that’s a good idea and I’ll test it. Here and there on internet I found details on other flavors of Android showint a setting to switch data from one SIM to another; I don’t see it on /e/ but maybe indeed this setting only appears when one has two SIMs inserted. If so, I’ll come back here to report.
@sylvain.gervais : Happy to see I was helpful! Was your problem on a Fairphone 3 too, or on another device?

FWIW, topic also addressed here in the Wiki

Yes Hervé it’s a FP3 with orange network too.

OK donc on était exactement dans la même situation… Heureux d’avoir découvert le contournement et qu’il puisse resservir! Je n’ai pas eu encore l’occasion d’essayer de mettre DEUX cartes, pour voir si par hasard ça permet d’accéder au choix de quelle carte est déiée à internet… Si j’y arrive, je reviendrai raconter ici…