Ongoing echo issues with some phone models

/e/OS has an issue which seems to have gone on and on unfixed, and I am curious to know why.

This post is not a dig at the team, the phone is a great job in protecting ones privacy from the prying eyes of big tech, but this ‘echo’ issue is a bit of a problem, is it unsolvable ??

It has taken a few months, but it has come to light for myself (and I’m sure others) that 3rd party callers to some /e/OS phones have experienced a serious echo, making their calls to /e/OS users more than difficult, some complaining that it is quite a serious echo…

/e/OS users will remain unaware of this issue unless the caller complains.

Searching this forum for ‘Echo’ reveals it is not just Samsung models (I have an S7) that suffer this with /e/OS but other phone makes too, from my reading some of these are actually purchased from /e/ themselves.

I have read all the forum posts and Gitlab issues I can find on this, some which go back to 2019.

From my understanding it appears that noise cancelling on the second Mic is either missing or not functioning properly. It occurs with either speaker turned on or off. There seem no current workarounds apart from using headphones, which untangling and stufffing in your ear at speed with a ringing phone is not always acheivable.

I don’t think I am alone in this, there are a long list of users who have experienced this issue.

Here are posts I can find on this echo issue:

Here are some of the Gitlab issues:
https://gitlab.e.foundation/e/backlog/-/issues/503

https://gitlab.e.foundation/e/backlog/-/issues/5824

https://gitlab.e.foundation/e/backlog/-/issues/6210

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

2 Likes

I had discussed this issue with the developers a few days back as regards Samsung phones and this was the response…

…There is a conflict between the hardware and software at some point that generates the echo in calls. Most likely due to some incompatibility somewhere between some components (Noise reduction microphone, modem?) and the software. This seems to be Samsung hardware specific.
Also it does not affect 100% of the users. It is impossible today to diagnose with certainty the root cause so we cannot anticipate or validate when it will happen. This issue is happening across all ROMs on Samsung hardware, so it is not /e/OS specific.
It is not solved by changing Android core version,
This was one of the reason why we have stopped selling older Samsung phones.
Regarding the S7, let’s keep in mind this phone has been released in 2016, end of life by Samsung in 2019. We’re in 2023. We need to understand if this situation will spread across these devices with newer Android versions, or if it can be solved with newer Android versions (most likely unlikely)…

1 Like

Hello,
I have this issue with my S9, but only when the loudspeaker is off.
No problem if I use a headset or if I turn the loudspeaker on.
I can deal with that as I don’t call very often but I would apreciate a solution :slight_smile:

Thats very helpful, and thanks for the swift reply.

This was one of the reason why we have stopped selling older Samsung phones
I presume its not so prevalent on new models then ?
My phone would have had this issue with its stock OS previous to me installing /e/OS on it ?

I use the S7 as I need a smaller phone to put in my pocket for work, not sure why manufacturers keep making phones bigger and bigger … they are impracticle in a pocket where physical work is involved.

3 Likes

As yet we have not tested any of the new Samsung devices. Will share updates if there is any progress on this.
Just wanted to check if any of the users of the forum have tested other custom ROMs running on the newer Samsung devices and seen this issue. Especially with Android 11, 12 or 13

I could trty create a ‘Poll’ in the Samsung Devices forum section, and try to see how prevalent this problem is, it would help gauage the probability of you being struck by this issue.

Are there stats available for how many users, on what devices ?

1 Like

Please include Motorola G7 Power (ocean) to look into!

Pl can you share /e/OS ver you are on. Also if you have raised any bug around this pl share the Gitlab ID

Moto ocean currently on 1.6

Gitlab issue no. is (#5938), it is mentioned in the OP here

Thanks

Ocean is now on v1.8.1 on both r and s. Maybe you should update and check.

On Samsungs own support site one thread alone has 131 replies, many from users with up to date phones, its showing as ‘solved’ - but that is done simply by booting into ‘safe mode’, which is not a daily driver mode:

https://eu.community.samsung.com/t5/galaxy-s21-series/problem-with-echo-on-call-s21-ultra/td-p/3252347

Some users suggest other fixes apart from ‘Safe Mode’ operation, turning off WiFi Calling, and Call Effects - but should I suspect theses are Samsung OneUI features.

Am I right that /e/OS sits on top of Samsungs hardware interface, and it is under this that the problem possibly exists, so the issue is with Samsung, not here … seems bizarre such a popular product should be plaqued by this problem.

This crude solution might work, tape over the noise cancelling mic. needs to be tested though:
https://www.youtube.com/watch?v=B9ZxXeFLvw0

Apologies to /e/ foundation …

I just tested my ocean with 1.8.1. Same problem!

Thanks @Manoj for providing that feedback and giving context and insight in the decisions.
It´s a pity for an S7-user like me but fully understandable that with the given (very high!) number of supported modells one has to live with imperfection of some sort here and there, least when it comes to endoflife-models combined with issues that are not 100% reproducable.
I linked yor statement into the two gitlab issues on S7 echos for reference.

You might simply change the title to “ongoing echo issues with some phone models” :slight_smile:

Thanks. Have asked the developers to check this issue, We were aware of the issue in the older Samsung phones but a Moto device also facing this problem is a new complaint.

Fairphone 4 user here reporting similar issues on /eos. Echos, reportedly worse on speakerphone. No problems when using a headset. Using /eos 1.8, just tonight updated to 1.9. Have been anxiously awaiting a fix for this rather annoying issue.

S7 now replaced with Galaxy S9 and S9 Plus, up and running with /e/OS easy installer, and no echo !

Great to be able to use the phone as it should be - guess I was sold the S7 as an unsuspecting customer, it took months for people on the other end to simply point out there was an echo - and I realise it was my end.

Looking forward to the upgrade from ‘Q’, which is due soon, and jumps ‘R’ and ‘S’ to ‘T’ I beleive.

Hi all

Issue with echo while speakerphone on is also experienced on a Motorola edge 20 pro (pstar) on e /os/ 2.1-t.